cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "sadhu suresh (JIRA)" <j...@apache.org>
Subject [jira] [Reopened] (CLOUDSTACK-2168) configured LDAP values not shown in UI
Date Wed, 03 Jul 2013 07:00:23 GMT

     [ https://issues.apache.org/jira/browse/CLOUDSTACK-2168?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

sadhu suresh reopened CLOUDSTACK-2168:
--------------------------------------


tested on latest build 140 and created values  shown on page initially    and when we refresh
the page then its not showing the details.

APi returns the details but its not shown in the UI.so reopening the bug

http://10.147.59.119:8080/client/api?command=ldapConfig&listall=true&response=json&sessionkey=zlWVnEF2HA3R4ekSa8kDXaZrY5k%3D&listAll=true&page=1&pagesize=20&_=1372834608618
{ "ldapconfigresponse" :  { "ldapconfig" : {"hostname":"10.147.38.163","port":"389","ssl":"false","searchbase":"CN=Users,DC=hyd-qa,DC=com","queryfilter":"(&amp;(mail=%e))","binddn":"CN=test,CN=Users,DC=hyd-qa,DC=com"}
}  }




                
> configured LDAP values not shown in UI
> --------------------------------------
>
>                 Key: CLOUDSTACK-2168
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-2168
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Management Server
>    Affects Versions: 4.2.0
>            Reporter: sadhu suresh
>            Assignee: Pranav Saxena
>            Priority: Critical
>             Fix For: 4.2.0
>
>         Attachments: cloudstack-2168.patch
>
>
> Steps:
> 1.Configured the LDAP through API
> http://10.147.59.83:8096/client/api?command=ldapConfig&hostname=10.147.38.163&searchbase=CN%3DUsers%2CDC%3Dhyd-qa%2CDC%3Dcom&queryfilter=%28%26%28mail%3D%25e%29%29&port=389&response=json
> 2.Open the CS web console and navigate to LDAP configuration section
> 3.check the displayed LDAP configured values
> Actual result:
> Even though LDAP configuration happens successfully but UI fail to display the Values.
> even firebug response shows the configured ldap values but UI fail to display the values.
> UI:
> ---
> Hostname	Query Filter	Search Base	LDAP Port	SSL	Quickview
> No data to show
> firebug response:
> ----
> http://10.147.59.83:8080/client/api?command=ldapConfig&listall=true&response=json&sessionkey=2G5uy2a4z%2F31Mi3yaVKmvXc10a4%3D&listAll=true&page=1&pagesize=20&_=1366791925255
> { "ldapconfigresponse" :  { "ldapconfig" : {"hostname":"10.147.38.163","port":"389","ssl":"false","searchbase":"CN=Users,DC=hyd-qa,DC=com","queryfilter":"(&(mail=%e))","binddn":""}
}  }

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message