cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas O'Dowd (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-3205) Object_Store_Refactor - unable to delete S3 Secondary Storage
Date Thu, 27 Jun 2013 00:58:19 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-3205?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13694382#comment-13694382
] 

Thomas O'Dowd commented on CLOUDSTACK-3205:
-------------------------------------------

The popup that I get is basically this which also appears in the terminal log.

INFO  [cloud.api.ApiServer] (352272606@qtp-885156424-26:) Cannot delete image store with active
templates backup!

As per step 6, the template should have been deleted and is not listed...

If I examine the S3 bucket, I can see this object...
template/tmpl/1/1/routing-1/acton-systemvm-02062012.vhd.bz2 2013-06-26T09:30:28.000Z None
140616708 "b533e7b65219439ee7fca0146ddd7ffa-27" 

However, I don't know how to delete this using the GUI. If I can't delete this S3 storage
then I cannot go back to using NFS storage either as the storage type is different and so
it cannot be added.
                
> Object_Store_Refactor - unable to delete S3 Secondary Storage
> -------------------------------------------------------------
>
>                 Key: CLOUDSTACK-3205
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-3205
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>    Affects Versions: 4.2.0
>         Environment: chrome on linux
> devcloud
>            Reporter: Thomas O'Dowd
>
> 1. Navigate to infrastructure, secondary storage.
> 2. Delete the NFS secondary storage
> 3. Add an S3 Object Storage
> 4. Navigate to Templates
> 5. Register a new Template
> 6. Remove the template
> 7. Navigate to infrastructure, secondary storage
> 8. try remove the S3 storage.
> I get a pop up which tells me I can't remove it. I haven't got the error in front of
me now as unfortunately started to deploy a new one so that I could do more testing. I think
I'm out of time today, but I'll find the error again tomorrow and update this bug. It was
something about not being able to delete a storage with active templates. However, I deleted
the template updated in step 5 in step 6. I could remove the NFS secondary storage, so I'm
curious why I couldn't remove the S3 one.
> In the meantime, is this expected behaviour and if so how do I remove the S3 storage
and use a different one instead. I also tried adding another S3 store and then removing this
one but the same error happens.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message