cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "venkata swamybabu budumuru (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CLOUDSTACK-3102) [DR] [add/list] ResourceDetail APIs only works for resourceType "volume/nic"
Date Fri, 21 Jun 2013 00:49:20 GMT
venkata swamybabu budumuru created CLOUDSTACK-3102:
------------------------------------------------------

             Summary: [DR] [add/list] ResourceDetail APIs only works for resourceType "volume/nic"

                 Key: CLOUDSTACK-3102
                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-3102
             Project: CloudStack
          Issue Type: Bug
      Security Level: Public (Anyone can view this level - this is the default.)
          Components: Management Server
    Affects Versions: 4.2.0
         Environment: commit # 971c40d98e07ab6cddb8e6db5095c1acea935815
            Reporter: venkata swamybabu budumuru
             Fix For: 4.2.0


Steps to reproduce :

1. Have CloudStack setup with at least 1 advanced zone
2. Try to insert key, value into user_vm_details using the following API

http://10.147.59.194:8096/api?command=addResourceDetail&resourceid=38&resourcetype=uservm&details[0].key=test&details[0].value=test

Tried to pass the vm id i.e. 38 and key, value in to user_details

Observations :-

(i) It went fine but, it inserted those key, values into nic_details table.


mysql> select * from nic_details;
+----+--------+------+-------+----------------+
| id | nic_id | name | value | display_detail |
+----+--------+------+-------+----------------+
|  1 |     38 | test | test  |              1 |
+----+--------+------+-------+----------------+

(ii)Tried to check the same with listResourceDetail and it fetches the info from nic_details
table.

http://10.147.59.194:8096/api?command=listResourceDetails&resourceType=uservm&resourceid=38

<listresourcedetailsresponse cloud-stack-version="4.2.0-SNAPSHOT"><count>1</count><nicdetail><resourcetype>Nic</resourcetype><key>test</key><value>test</value></nicdetail></listresourcedetailsresponse>

(iii) looked into the code and found that if addResourceDetail is executed on Volume then
things go fine otherwise, we are inserting everything into nic_details table.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message