cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sudha Ponnaganti (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CLOUDSTACK-2384) Template created from snapshot or root disk is not displayed in the templates view in VMware setup.
Date Wed, 22 May 2013 12:18:20 GMT

     [ https://issues.apache.org/jira/browse/CLOUDSTACK-2384?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sudha Ponnaganti updated CLOUDSTACK-2384:
-----------------------------------------

    Priority: Blocker  (was: Critical)
    
> Template created from snapshot or root disk is not displayed in the templates view in
VMware setup.
> ---------------------------------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-2384
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-2384
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Snapshot
>    Affects Versions: 4.2.0
>         Environment: Vmware
>            Reporter: Kiran Koneti
>            Assignee: Fang Wang
>            Priority: Blocker
>             Fix For: 4.2.0
>
>
> The below are the steps followed.
> I created a VM with a root disk and data disk using the windows 2012 and windows 8 32bit
ISO's.
> Case 1:
> In the case 1 stopped the windows 2012 machine and created the template the aysnc job
shows completed for the same case but the template is not displayed in the UI. 
>  I waited for longer time i.e almost 1 day then I was able to see the same in the UI
of the templates view.
> The DB details for the same still shows allocated and all the details are as below:
> *************************** 20. row ***************************
>                  id: 210
>         unique_name: 221a6cfd2-f609-3cb6-a879-afdc47ca2c43
>                name: Winserve8
>                uuid: 0efb17b3-13d0-4e25-bb9b-709a4e71f584
>              public: 1
>            featured: 1
>                type: USER
>                 hvm: 1
>                bits: 64
>                 url: NULL
>              format: OVA
>             created: 2013-05-07 15:44:19
>             removed: NULL
>          account_id: 2
>            checksum: 93418461b411aa5559bc978a9b0d73f3
>        display_text: Winserve8
>     enable_password: 0
>       enable_sshkey: 0
>         guest_os_id: 168
>            bootable: 1
>         prepopulate: 0
>         cross_zones: 0
>         extractable: 1
>     hypervisor_type: VMware
>  source_template_id: 204
>        template_tag: NULL
>            sort_key: 0
>                size: NULL
>               state: Allocated
>        update_count: 0
>             updated: NULL
> image_data_store_id: 1
> I initially observed only the ovf file and later after a day I was able to see the .vmdk,.ova
and also templates.properties file.
> Case2:
> In the case 2 I took a snapshot of the windows 2012 root disk.
> from this snapshot I tried to create a template then I observed the similar behaviour.
> investigating into deep I found that the secondary storage has only the .ovf file and
the details of the snapshot are as below:
> "*************************** 21. row ***************************
>                  id: 211
>         unique_name: 272531697-0e83-3556-8a7f-346aa8d58beb
>                name: CreatedfromSnapshot
>                uuid: d110660c-48cf-4362-875a-e3ae068ef89d
>              public: 1
>            featured: 0
>                type: USER
>                 hvm: 1
>                bits: 64
>                 url: NULL
>              format: RAW
>             created: 2013-05-08 14:25:04
>             removed: NULL
>          account_id: 2
>            checksum: NULL
>        display_text: win8server
>     enable_password: 0
>       enable_sshkey: 0
>         guest_os_id: 168
>            bootable: 1
>         prepopulate: 0
>         cross_zones: 0
>         extractable: 0
>     hypervisor_type: VMware
>  source_template_id: 204
>        template_tag: NULL
>            sort_key: 0
>                size: NULL
>               state: Allocated
>        update_count: 0
>             updated: NULL
> image_data_store_id: 1"
> I observed the same behaviour even with the centos VM .

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message