cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ryan Lei - Taiwan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-1907) Can't create system VM on XCP1.6 hypervisor
Date Thu, 09 May 2013 02:28:13 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-1907?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13652684#comment-13652684
] 

Ryan Lei - Taiwan commented on CLOUDSTACK-1907:
-----------------------------------------------

I'm glad to see this fixed, but there are some other changes in the supported guest os type
as of XCP 1.6 (at least in my XCP 1.6.10).

For example, Windows 8 (32-bit/64-bit), Ubuntu 10.10, 12.04 , Solaris 10 (all experimental).
Maybe it's best to completely go through the list in XCP 1.6.x, instead of copying the current
list and just fix the ones for System VMs.

Thanks!
                
> Can't create system VM on XCP1.6 hypervisor
> -------------------------------------------
>
>                 Key: CLOUDSTACK-1907
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-1907
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>    Affects Versions: 4.0.1, 4.1.0
>         Environment: centos 6.3 management server with CS v4
> XCP 1.6
>            Reporter: Nikita Gubenko
>            Assignee: edison su
>            Priority: Critical
>             Fix For: 4.1.0
>
>         Attachments: xcp1.6-debianfix.sh
>
>
> Hello
> I'm trying to set cloudstack v4 with XCP 1.6 host and can't start system VMs. They are
trying to start over and over again but get 
> 2013-04-03 17:31:00,894 WARN  [xen.resource.CitrixResourceBase] (DirectAgent-123:null)
Catch Exception: class java.util.NoSuchElementException due to java.util.NoSuchElementException
> java.util.NoSuchElementException
>         at java.util.LinkedHashMap$LinkedHashIterator.nextEntry(LinkedHashMap.java:392)
>         at java.util.LinkedHashMap$KeyIterator.next(LinkedHashMap.java:401)
>         at com.cloud.hypervisor.xen.resource.CitrixResourceBase.createVmFromTemplate(CitrixResourceBase.java:991)
>         at com.cloud.hypervisor.xen.resource.CitrixResourceBase.execute(CitrixResourceBase.java:1300)
>         at com.cloud.hypervisor.xen.resource.CitrixResourceBase.executeRequest(CitrixResourceBase.java:517)
>         at com.cloud.hypervisor.xen.resource.XcpServerResource.executeRequest(XcpServerResource.java:52)
>         at com.cloud.agent.manager.DirectAgentAttache$Task.run(DirectAgentAttache.java:186)
>         at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
>         at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
>         at java.util.concurrent.FutureTask.run(FutureTask.java:166)
>         at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(ScheduledThreadPoolExecutor.java:165)
>         at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:266)
>         at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
>         at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
>         at java.lang.Thread.run(Thread.java:679)
> At XCP host I see weird entries in log
> Apr  3 17:31:25 cl1 xapi: [debug|cl1|79180 UNIX /var/xapi/xapi|event.next D:d52669e39266|dispatcher]
Server_helpers.exec exception_handler: Got exception SESSION_INVALID: [ OpaqueRef:a7d7273f-e2bb-67cf-9f45-b04ec9a675bc
]
> Apr  3 17:31:25 cl1 xapi: [debug|cl1|85310 UNIX /var/xapi/xapi|session_check D:04f6a0c5a8d1|dispatcher]
Server_helpers.exec exception_handler: Got exception SESSION_INVALID: [ OpaqueRef:a7d7273f-e2bb-67cf-9f45-b04ec9a675bc
]
> Apr  3 17:31:30 cl1 xapi: [debug|cl1|85343 UNIX /var/xapi/xapi|VDI.get_by_uuid D:557eae029b09|dispatcher]
Server_helpers.exec exception_handler: Got exception UUID_INVALID: [ VDI; d5f5ad17-ac1b-463d-a9d3-e6f94675a7f7
]
> Apr  3 17:32:30 cl1 xapi: [debug|cl1|85526 UNIX /var/xapi/xapi|VDI.get_by_uuid D:e57dbbf0b9de|dispatcher]
Server_helpers.exec exception_handler: Got exception UUID_INVALID: [ VDI; b4791ecf-eef1-485f-837e-152de4af29bc
]
> I've already tried 4.0.1 & 4.1.0. Here is some part of the log file http://37.140.192.213:81/management-server.txt
> Is it a bug or something wrong with my setup?
> Thanks

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message