cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nawawit Kessaraphong (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-2214) DB upgrade from 3.0.2 -> 4.0.2 is broken
Date Fri, 26 Apr 2013 16:40:15 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-2214?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13643008#comment-13643008
] 

Nawawit Kessaraphong commented on CLOUDSTACK-2214:
--------------------------------------------------

I can confirm. This happened to me as well.


                
> DB upgrade from 3.0.2 -> 4.0.2 is broken
> ----------------------------------------
>
>                 Key: CLOUDSTACK-2214
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-2214
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Management Server
>    Affects Versions: 4.0.2
>         Environment: CentOS 6 + vSphere
>            Reporter: Tamas Monos
>            Priority: Blocker
>
> Hi,
> I have tried an upgrade according to the upgrade instructions set out here:
> http://cloudstack.apache.org/docs/en-US/Apache_CloudStack/4.0.2/pdf/Release_Notes/Apache_CloudStack-4.0.2-Release_Notes-en-US.pdf
> Packages upgraded:
> Installed:
>   cloud-scripts.x86_64 0:4.0.2-1.el6                                            
> Dependency Installed:
>   apache-tomcat-apis.noarch 0:0.1-1.el6                                         
>   cloud-aws-api.x86_64 0:4.0.2-1.el6                                            
>   geronimo-specs.noarch 0:1.0-3.5.M2.el6                                        
>   geronimo-specs-compat.noarch 0:1.0-3.5.M2.el6                                 
>   jakarta-commons-daemon-jsvc.x86_64 1:1.0.1-8.9.el6                            
>   jakarta-commons-lang.noarch 0:2.4-1.1.el6                                     
>   mysql-connector-java.noarch 1:5.1.17-6.el6                                    
>   slf4j.noarch 0:1.5.8-8.el6                                                    
> Updated:
>   cloud-client.x86_64 0:4.0.2-1.el6     cloud-client-ui.x86_64 0:4.0.2-1.el6    
>   cloud-core.x86_64 0:4.0.2-1.el6       cloud-deps.x86_64 0:4.0.2-1.el6         
>   cloud-python.x86_64 0:4.0.2-1.el6     cloud-server.x86_64 0:4.0.2-1.el6       
>   cloud-setup.x86_64 0:4.0.2-1.el6      cloud-usage.x86_64 0:4.0.2-1.el6        
>   cloud-utils.x86_64 0:4.0.2-1.el6
> Repo URL: http://cloudstack.apt-get.eu/rhel/4.0/
> When I start the management server I get a FATAL error:
> 2013-04-26 16:57:56,759 DEBUG [upgrade.dao.VersionDaoImpl] (main:null) Checking to see
if the database is at a version before it was the version table is created
> 2013-04-26 16:57:56,765 INFO  [cloud.upgrade.DatabaseUpgradeChecker] (main:null) DB version
= 3.0.2.20120506223416 Code Version = 4.0.2.20130420145617
> 2013-04-26 16:57:56,765 INFO  [cloud.upgrade.DatabaseUpgradeChecker] (main:null) Database
upgrade must be performed from 3.0.2.20120506223416 to 4.0.2.20130420145617
> 2013-04-26 16:57:56,765 ERROR [cloud.upgrade.DatabaseUpgradeChecker] (main:null) The
end upgrade version is actually at 4.0.0 but our management server code version is at 4.0.2.20130420145617
> 2013-04-26 16:57:56,776 ERROR [utils.component.ComponentLocator] (main:null) Problems
with running checker:DatabaseUpgradeChecker
> com.cloud.utils.exception.CloudRuntimeException: The end upgrade version is actually
at 4.0.0 but our management server code version is at 4.0.2.20130420145617
>         at com.cloud.upgrade.DatabaseUpgradeChecker.upgrade(DatabaseUpgradeChecker.java:211)
>         at com.cloud.upgrade.DatabaseUpgradeChecker.check(DatabaseUpgradeChecker.java:369)
>         at com.cloud.utils.component.ComponentLocator.runCheckers(ComponentLocator.java:273)
>         at com.cloud.utils.component.ComponentLocator.parse(ComponentLocator.java:245)
>         at com.cloud.utils.component.ComponentLocator.getLocatorInternal(ComponentLocator.java:836)
>         at com.cloud.utils.component.ComponentLocator.getLocator(ComponentLocator.java:874)
>         at com.cloud.utils.component.ComponentLocator.getComponent(ComponentLocator.java:416)
>         at com.cloud.utils.component.ComponentLocator.getComponent(ComponentLocator.java:409)
>         at com.cloud.servlet.CloudStartupServlet.init(CloudStartupServlet.java:44)
>         at javax.servlet.GenericServlet.init(GenericServlet.java:212)
>         at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1173)
>         at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:993)
>         at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4187)
>         at org.apache.catalina.core.StandardContext.start(StandardContext.java:4496)
>         at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:791)
>         at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:771)
>         at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:526)
>         at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1041)
>         at org.apache.catalina.startup.HostConfig.deployDirectories(HostConfig.java:964)
>         at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:502)
>         at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1277)
>         at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:321)
>         at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
>         at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1053)
>         at org.apache.catalina.core.StandardHost.start(StandardHost.java:722)
>         at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
>         at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
>         at org.apache.catalina.core.StandardService.start(StandardService.java:516)
>         at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
>         at org.apache.catalina.startup.Catalina.start(Catalina.java:593)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
>         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
>         at java.lang.reflect.Method.invoke(Method.java:616)
>         at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)
>         at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message