cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marcus Sorensen (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CLOUDSTACK-1948) users can no longer set global limits to -1 (e.g. pagesize)
Date Fri, 05 Apr 2013 00:44:15 GMT
Marcus Sorensen created CLOUDSTACK-1948:
-------------------------------------------

             Summary: users can no longer set global limits to -1 (e.g. pagesize)
                 Key: CLOUDSTACK-1948
                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-1948
             Project: CloudStack
          Issue Type: Improvement
      Security Level: Public (Anyone can view this level - this is the default.)
          Components: Management Server
    Affects Versions: 4.1.0
            Reporter: Marcus Sorensen
             Fix For: 4.1.0


Just installed 4.1 over a 4.0 install, and ran into an issue where the max pagesize global
parameter was set to -1, which worked to effectively disable paging in 4.0, but 4.1 passes
the -1 right on to the SQL query, which mysql hates.

management server log shows  "LIMIT 0, -1" in mysql statements. I'm assuming that a non-positive
integer used to just remove the limit clause, since it worked in 4.0



--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message