cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "venkata swamybabu budumuru (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CLOUDSTACK-1867) [VMware] [SystemVMTemplate] is not working with latest cloudstack master
Date Mon, 01 Apr 2013 11:39:15 GMT
venkata swamybabu budumuru created CLOUDSTACK-1867:
------------------------------------------------------

             Summary: [VMware] [SystemVMTemplate] is not working with latest cloudstack master
                 Key: CLOUDSTACK-1867
                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-1867
             Project: CloudStack
          Issue Type: Bug
      Security Level: Public (Anyone can view this level - this is the default.)
          Components: Management Server
    Affects Versions: 4.2.0
         Environment: commit # 355589c1f0c583cbbdc601f74dba504064f81bac

- Advanced zone with VMware cluster
            Reporter: venkata swamybabu budumuru
            Priority: Blocker
             Fix For: 4.2.0


Steps to reproduce :

1. Took the latest system vm template from jenkins 

http://jenkins.cloudstack.org/view/master/job/build-systemvm-master/lastSuccessfulBuild/artifact/tools/appliance/dist/systemvmtemplate-2013-03-27-master-vmware.ova

2. Seeded the above template using the following 

/usr/share/cloudstack-common/scripts/storage/secondary/cloud-install-sys-tmplt -m /tmp/1/secondary.campo.vmw.GOLD/
-u http://10.147.28.7/templates/campo/templates/systemvmtemplate-2013-03-27-master-vmware.ova
-h vmware -F

3. Tried to bring up the advanced zone using ESXi 5.1 

Observations : 

(i) Found the following error in vmops.log

2013-04-01 11:16:33,856 INFO  [vmware.manager.VmwareStorageManagerImpl] (DirectAgent-6:10.147.40.12)
Secondary storage mount point: /mnt/VM/7280707764394.cc4bce7
2013-04-01 11:16:33,863 DEBUG [cloud.alert.AlertManagerImpl] (CapacityChecker:null) Done running
Capacity Checker ...
2013-04-01 11:16:34,832 ERROR [vmware.manager.VmwareStorageManagerImpl] (DirectAgent-6:10.147.40.12)
Unable to execute PrimaryStorageDownloadCommand due to exception
javax.xml.ws.soap.SOAPFaultException:
Required parameter spec is missing

while parsing call information for method ImportVApp
at line 1, column 110

while parsing SOAP body
at line 1, column 102

while parsing SOAP envelope
at line 1, column 38

while parsing HTTP request for method importVApp
on object of type vim.ResourcePool
at line 1, column 0
        at com.sun.xml.internal.ws.fault.SOAP11Fault.getProtocolException(SOAP11Fault.java:178)
        at com.sun.xml.internal.ws.fault.SOAPFaultBuilder.createException(SOAPFaultBuilder.java:119)
        at com.sun.xml.internal.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:108)
        at com.sun.xml.internal.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:78)
        at com.sun.xml.internal.ws.client.sei.SEIStub.invoke(SEIStub.java:107)
        at sun.proxy.$Proxy89.importVApp(Unknown Source)
        at com.cloud.hypervisor.vmware.mo.HypervisorHostHelper.importVmFromOVF(HypervisorHostHelper.java:995)
        at com.cloud.hypervisor.vmware.mo.HostMO.importVmFromOVF(HostMO.java:681)
        at com.cloud.hypervisor.vmware.manager.VmwareStorageManagerImpl.copyTemplateFromSecondaryToPrimary(VmwareStorageManagerImpl.java:478)
        at com.cloud.hypervisor.vmware.manager.VmwareStorageManagerImpl.execute(VmwareStorageManagerImpl.java:153)
        at com.cloud.hypervisor.vmware.resource.VmwareResource.execute(VmwareResource.java:3660)
        at com.cloud.hypervisor.vmware.resource.VmwareResource.executeRequest(VmwareResource.java:414)
        at com.cloud.agent.manager.DirectAgentAttache$Task.run(DirectAgentAttache.java:186)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
        at java.util.concurrent.FutureTask.run(FutureTask.java:166)
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(ScheduledThreadPoolExecutor.java:165)
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:266)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1146)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
        at java.lang.Thread.run(Thread.java:679)
2013-04-01 11:16:34,836 DEBUG [agent.manager.DirectAgentAttache] (DirectAgent-6:null) Seq
5-379977770: Response Received:
2013-04-01 11:16:34,836 DEBUG [agent.transport.Request] (DirectAgent-6:null) Seq 5-379977770:
Processing:  { Ans: , MgmtId: 7280707764394, via: 5, Ver: v1, Flags: 110, [{"storage.PrimaryStorageDownloadAnswer":{"templateSize":0,"result":false,"details":"Unable
to execute PrimaryStorageDownloadCommand due to exception","wait":0}}] }


(ii) Tried to manually import the system ova from vCenter and it failed with the following
error.

The OVF package requires unsupported hardware.
Details : Line 25: Unsupported hardware family 'virtualbox-2.2'

(iv) As per the above message it looks like we made those templates out of virtual box and
we need to change the corresponding setting in ovf to say ESX / something like that. 

Attaching vmops.log, api.log, ovf xml data, error vCenter Error Screenshot.


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message