cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alena Prokharchyk (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-1697) Six DB tables are not available with upgraded setup(4.0 to 4.1) when compare to 4.1 newly installation
Date Fri, 15 Mar 2013 23:02:12 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-1697?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13603956#comment-13603956
] 

Alena Prokharchyk commented on CLOUDSTACK-1697:
-----------------------------------------------

The features for all these tables are part of 4.2, not 4.1. So they are handled as a part
of 4.1->4.2 DB upgrade.

I've also checked 4.1 branch, none of these tables are part of it. 

Sailaja, I suspect that your setup has these tables from 4.2 installation. So please do your
test as follows:

1) Drop cloud database.
2) Install fresh 4.1 build, take the DB dump from it
3) Drop cloud database
4) Upgrade from 4.0 to 4.1. Take the DB of upgraded setup.


Compare the DB dumps taken on step 2) and 4).
                
> Six DB tables are not available with upgraded setup(4.0 to 4.1) when compare to 4.1 newly
installation
> ------------------------------------------------------------------------------------------------------
>
>                 Key: CLOUDSTACK-1697
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-1697
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Install and Setup
>    Affects Versions: 4.1.0
>            Reporter: Sailaja Mada
>            Assignee: Alena Prokharchyk
>            Priority: Critical
>             Fix For: 4.1.0
>
>
> Setup: Advanced Networking Zone with Xen 6.0.2 
> Steps:
> 1. Upgrade from 4.0 to 4.1
> Observation:
> Tried database comparison  between 4.1 new installation vs upgrade from 4.0 to 4.1.
> There are 6 tables that are not available with upgraded setup when compare to 4.1 newly
installation.
> 1)      data_store_provider
> 2)      image_data_store
> 3)      nic_secondary_ips
> 4)      object_datastore_ref
> 5)      user_vm_clone_setting
> 6)      vpc_service_map

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message