cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marcus Sorensen (JIRA)" <>
Subject [jira] [Commented] (CLOUDSTACK-1591) Cannot reconnect KVM host to management server
Date Mon, 18 Mar 2013 23:15:15 GMT


Marcus Sorensen commented on CLOUDSTACK-1591:

I thought that might be the case, but I tried it last week and that didn't do the trick. Was
still getting the same AncientPrimaryDatastore trace.
> Cannot reconnect KVM host to management server
> ----------------------------------------------
>                 Key: CLOUDSTACK-1591
>                 URL:
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Storage Controller
>    Affects Versions: 4.2.0
>         Environment: devcloud-kvm (CentOS 6.3 box acting as Management server and host,
local storage), tools/marvin/devcloud-kvm/devcloud-kvm-advanced.cfg marvin config
>            Reporter: Marcus Sorensen
>            Assignee: Marcus Sorensen
>            Priority: Blocker
>             Fix For: 4.2.0
> Tried running master branch today, everything came up ok, but when I tried to restart
the cloudstack-agent service, it couldn't reconnect to the management server. The system was
complaining about the local storage pool, saying it's a duplicate pool. If I go to the host
and delete the pool, when the agent tries to reconnect the pool is just recreated, but the
same error is thrown. Should probably do a getPool first and if the uuid exists, with correct
path, call it good rather than complaining about a duplicate.
> Management server:
> 2013-03-07 13:32:07,033 WARN  [] (AgentConnectTaskPool-10:null)
Unable to setup the local storage pool for Host[-1-Routing]
> Another active pool with the same uuid
already exists
> 	at
> 	at
> 2013-03-07 13:32:17,553 WARN  [agent.manager.AgentManagerImpl] (AgentConnectTaskPool-11:null)
Monitor LocalStoragePoolListener says there is an error in the connect process for 1 due to
Unable to setup the local storage pool for Host[-1-Routing]

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

View raw message