cloudstack-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rohit Yadav (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-1505) Unknown column 'domain.region_id' in 'field list'
Date Thu, 14 Mar 2013 09:04:12 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-1505?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13602151#comment-13602151
] 

Rohit Yadav commented on CLOUDSTACK-1505:
-----------------------------------------

Hi Marcus, sorry for my late reply was caught is a lot of frivolous things. So, the idea is
that we fix the base create-schema version and databasecreator would apply sort of patches
or upgrade paths (sql files) so during fresh db deployment, it would run 4.0 create-schema
and apply upgrade path schemas. This will ensure that in future when someone does fresh install
or upgrades we use the same method of db deployment, therefore upgrade bugs and issues could
be caught early on and fixed + we've a rolling upgrade case. You can read more about the tool
and db deployment process and pl. let me know about your views, comments/suggestions: (add/remove/edit
wiki as need :)
https://cwiki.apache.org/confluence/display/CLOUDSTACK/Database+Creator 

So, I'm not getting this bug. Can you confirm if it was a db deployment from scratch or upgrade
from 4.0.1 or 4.0.2?
                
> Unknown column 'domain.region_id' in 'field list'
> -------------------------------------------------
>
>                 Key: CLOUDSTACK-1505
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-1505
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Management Server
>    Affects Versions: 4.1.0
>         Environment: Management server running on CentOS 6.3
>            Reporter: Marcus Sorensen
>            Assignee: Marcus Sorensen
>            Priority: Critical
>             Fix For: 4.1.0
>
>
> I deploy a management server and database. Then I stop management server, drop database,
and then attempt to reinstall. I run:
> cloudstack-setup-databases cloud:password@localhost --deploy-as root
> cloudstack-setup-management
> as I also did during initial successful install. Only this time, I cannot log in as Admin
user. The UI does nothing when I attempt to login, and management server says:
> 2013-03-04 16:30:18,950 ERROR [cloud.api.ApiServlet] (catalina-exec-14:null) unknown
exception writing api response
> com.cloud.utils.exception.CloudRuntimeException: DB Exception on: com.mysql.jdbc.JDBC4PreparedStatement@18f7d92f:
SELECT domain.id, domain.parent, domain.name, domain.owner, domain.path, domain.level, domain.removed,
domain.child_count, domain.next_child_seq, domain.state, domain.network_domain, domain.uuid,
domain.region_id FROM domain WHERE domain.path = _binary'/'  AND domain.removed IS NULL  ORDER
BY RAND() LIMIT 1
> Caused by: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Unknown column
'domain.region_id' in 'field list'
> Indeed, there is no mention of region_id in the sql deployment, and perhaps whatever
injects this into the schema doesn't like a reinstall. This could be hard on devs and people
testing out cloudstack.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message