cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Lawley <rich...@richardlawley.com>
Subject Is anyone using SRX Integration?
Date Fri, 07 Jun 2019 07:15:36 GMT
Hi,

We've recently added a couple of Juniper SRXs, but are finding that
the integration with CloudStack is very broken.  So far there have
been a number of things which just don't work:
* Adding Static NAT Rules
* Adding Port Forwarding Rules
* Removing Port Forwarding Rules

I've found and fixed locally some of these things, but I'm trying to
work out whether this functionality ever worked?  The "Supported
External Devices" on the CloudStack website lists "SRX (Model srx100b)
versions 10.3 to 10.4 R7.5" - JunOS 10 went EOL in 2014.  We've been
using 15.x, so either the functionality never worked, or the changes
in JunOS broke compatibility with CloudStack.

I'm working finding and fixing the functionality, but I'd be
interested to know whether anyone was actively using any of this
integration, as if so, the fixes I apply may well break compatibility
with (much) older versions.

Regards,

Richard

Mime
View raw message