cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jayapal Uradi <jayapal.ur...@accelerite.com>
Subject Re: Is anyone using SRX Integration?
Date Fri, 07 Jun 2019 07:20:03 GMT
Hi,

The mentioned functionalities works with  JunOs 10.x.
Not used JunOs 15.x. May be backward compatibility issues.


Thanks,
Jayapal


On 07-Jun-2019, at 12:45 PM, Richard Lawley <richard@richardlawley.com<mailto:richard@richardlawley.com>>
wrote:

Hi,

We've recently added a couple of Juniper SRXs, but are finding that
the integration with CloudStack is very broken.  So far there have
been a number of things which just don't work:
* Adding Static NAT Rules
* Adding Port Forwarding Rules
* Removing Port Forwarding Rules

I've found and fixed locally some of these things, but I'm trying to
work out whether this functionality ever worked?  The "Supported
External Devices" on the CloudStack website lists "SRX (Model srx100b)
versions 10.3 to 10.4 R7.5" - JunOS 10 went EOL in 2014.  We've been
using 15.x, so either the functionality never worked, or the changes
in JunOS broke compatibility with CloudStack.

I'm working finding and fixing the functionality, but I'd be
interested to know whether anyone was actively using any of this
integration, as if so, the fixes I apply may well break compatibility
with (much) older versions.

Regards,

Richard

DISCLAIMER
==========
This e-mail may contain privileged and confidential information which is the property of Accelerite,
a Persistent Systems business. It is intended only for the use of the individual or entity
to which it is addressed. If you are not the intended recipient, you are not authorized to
read, retain, copy, print, distribute or use this message. If you have received this communication
in error, please notify the sender and delete all copies of this message. Accelerite, a Persistent
Systems business does not accept any liability for virus infected mails.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message