cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rohit Yadav <rohit.ya...@shapeblue.com>
Subject Re: Do not see KVM Hosts after 4.9.3 -> 4.11.2
Date Fri, 31 May 2019 05:07:40 GMT
Sean,


Can you try to drop and recreate host_view, as in your DB:

https://github.com/apache/cloudstack/blob/master/engine/schema/src/main/resources/META-INF/db/schema-41000to41100.sql#L159


Regards,

Rohit Yadav

Software Architect, ShapeBlue

https://www.shapeblue.com

________________________________
From: Sean Lair <slair@ippathways.com>
Sent: Friday, May 31, 2019 3:34:18 AM
To: dev@cloudstack.apache.org
Subject: Do not see KVM Hosts after 4.9.3 -> 4.11.2

After upgrading from 4.9.3 to 4.11.2, we no longer see hosts in the CloudStack web-interface.
 Hitting the listHosts API directly also does not return any results.  It's just an empty
list.  When looking in the DB we do see the hosts and there are rows where the version is
4.11.2.0.

The agent.log on the KVM (CentOS 7) looks good.  We can see a list of running VMs in CloudStack
and their Running/Stopped statuses look good.  We can see Zones/Pods/Clusters, just not Hosts.
 The "Infrastructure" page also correctly says "2" in the Host Count.  But when we Click Hosts
it just says:

No data to show

Any ideas?

Thanks
Sean






rohit.yadav@shapeblue.comĀ 
www.shapeblue.com
Amadeus House, Floral Street, London  WC2E 9DPUK
@shapeblue
  
 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message