cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Francois Nadeau <the.jfnad...@gmail.com>
Subject Re: SSVM, templates and managed storage (iscsi/KVM)... how does it work ?
Date Sun, 03 Mar 2019 19:41:38 GMT
I just found my problem in regards to the managed storage.... for some
reason,  the hypervisor type on the primary storage must be set to any and
not KVM (just Like solidfire).    The VM now boots from the template but Im
still wondering how did that happen :)


On Sun, Mar 3, 2019 at 2:33 PM Ivan Kudryavtsev <kudryavtsev_ia@bw-sw.com>
wrote:

> Not sure, KVM works on arbitrary iSCSI target except the Solidfire.
>
> вс, 3 мар. 2019 г. в 14:10, Jean-Francois Nadeau <the.jfnadeau@gmail.com>:
>
> > Hi Ivan,
> >
> > SS is still on NFS in this case.  It's the primary storage in trying to
> > move on iscsi managed storage so just like Solidfire/Ceph on primary.
> >
> > While NFS is used on both SS and primary,  I understand the SSVM just
> > mounts both shares and copies templates when needed.
> >
> > But if you have a qcow2 template on SS,  and primary on managed
> storage,  I
> > presume the SSVM copies the qcow2 into the just dynamically created iscsi
> > volume in a raw way....  but I don't know that is what Im trying to
> connect
> > the dots :)
> >
> >
> > On Sun, Mar 3, 2019 at 2:02 PM Ivan Kudryavtsev <
> kudryavtsev_ia@bw-sw.com>
> > wrote:
> >
> > > Jean-Francois,
> > > NFS primary, NFS secondary worked always like a charm. It's the most
> used
> > > way for CloudStack, I suppose. It works great for my 4.11.2, worked
> great
> > > for 4.11.1 and even for full-trash 4.10 release.
> > >
> > > I have never tried SS on iSCSI and suppose it's a wrong way to go
> except
> > > the way you use Solidfire. For KVM you must use NFS, S3 or Swift.
> > >
> > >
> > > вс, 3 мар. 2019 г. в 13:50, Jean-Francois Nadeau <
> the.jfnadeau@gmail.com
> > >:
> > >
> > > > Hi all,
> > > >
> > > > Im kicking the tires with managed storage with under 4.11.2 with KVM
> > and
> > > > Datera as primary storage.
> > > >
> > > > My first attempt at creating a VM from a template stored on NFS
> > secondary
> > > > failed silently. Looking at the SSVM cloud logs I saw no exception.
> > The
> > > VM
> > > > root disks gets properly created on the backend and attached on the
> KVM
> > > > host but the block device is blank.  Somehow the template did not get
> > > > copied over.
> > > >
> > > > Starting troubleshooting from this point... I realize I don't
> > understand
> > > > how this work vs what Im used to with NFS as both primary and
> secondary
> > > > storage.
> > > >
> > > > I presume the SSVM has to copy the qcow2 template from the NFS
> > secondary
> > > to
> > > > the primary storage but this one is iscsi now... and I did not setup
> > > > initiator access to the SSVM or found instructions I need to do that.
> > > >
> > > > Can someone fill the blank on to how this work ?
> > > >
> > > > thanks all,
> > > >
> > > > Jean-Francois
> > > >
> > >
> > >
> > > --
> > > With best regards, Ivan Kudryavtsev
> > > Bitworks LLC
> > > Cell RU: +7-923-414-1515
> > > Cell USA: +1-201-257-1512
> > > WWW: http://bitworks.software/ <http://bw-sw.com/>
> > >
> >
>
>
> --
> With best regards, Ivan Kudryavtsev
> Bitworks LLC
> Cell RU: +7-923-414-1515
> Cell USA: +1-201-257-1512
> WWW: http://bitworks.software/ <http://bw-sw.com/>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message