cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From li jerry <div...@hotmail.com>
Subject 答复: 答复: CloudStack 4.11.2 Snapshot Revert fail
Date Wed, 23 Jan 2019 09:36:47 GMT

I modified and recompiled cloudstack4.11.2, and then I can complete the xenserver vm snapshot
recovery.

plugins/hypervisors/xenserver/src/com/cloud/hypervisor/xenserver/resource/CitrixResourceBase.java


public VM createWorkingVM(final Connection conn, final String vmName, final String guestOSType,
final String platformEmulator, final List<VolumeObjectTO> listVolumeTo)
 throws BadServerResponse, Types.VmBadPowerState, Types.SrFull, Types.OperationNotAllowed,
XenAPIException, XmlRpcException {
 // below is redundant but keeping for consistency and code readabilty
 //final String guestOsTypeName = platformEmulator;
 String guestOsTypeName = platformEmulator;
if (guestOsTypeName == null) {
 final String msg = " Hypervisor " + this.getClass().getName() + " doesn't support guest OS
type " + guestOSType + ". you can choose 'Other install media' to run it as HVM";
 s_logger.warn(msg);
 //throw new CloudRuntimeException(msg);
  guestOsTypeName = "Other install media";
}


This rude modification, I don’t know if it will create other new problems….





发件人: li jerry<mailto:div8cn@hotmail.com>
发送时间: 2019年1月23日 17:16
收件人: users@cloudstack.apache.org<mailto:users@cloudstack.apache.org>; dev<mailto:dev@cloudstack.apache.org>
抄送: users@cloudstack.apache.org<mailto:users@cloudstack.apache.org>
主题: 答复: 答复: CloudStack 4.11.2 Snapshot Revert fail

I tried, modified the VM to CENTOS6.5 (64-bit) and reported the same error.



发件人: Andrija Panic<mailto:andrija.panic@gmail.com>
发送时间: 2019年1月23日 16:38
收件人: dev<mailto:dev@cloudstack.apache.org>
抄送: users@cloudstack.apache.org<mailto:users@cloudstack.apache.org>
主题: Re: 答复: CloudStack 4.11.2 Snapshot Revert fail

Hi,

Did you try with other OS types - message above suggests that your Xen is
seen as 6.5 version and doesn't support CentOS 7 - can you try to edit the
VM to CentOS 6 or CentOS 7.1/7.2 etc ? Does the revert works then ?

On Wed, 23 Jan 2019 at 02:58, Haijiao <18602198181@163.com> wrote:

> This is a fresh installation (XenSever 7.1.2+ACS 4.11.2).
>
>
>
> We simply can not revert the VM snapshot though there's no changes at all
> to VM or template.
>
>
> We can consistently reproduce this issue in our environtment with the
> error log attached. And we believe the issue doesn't exisit in another
> environment ( XenServer 6.5+ACS 4.7.1).
>
>
>
>

--

Andrija Panić

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message