cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ivan Kudryavtsev <kudryavtsev...@bw-sw.com>
Subject RFC. Marvin tests fail
Date Wed, 07 Nov 2018 18:52:38 GMT
Hello, dev team. Now I try to put a PR and need to write marvin test for
it. I did it in the past, so tried to recall how to run the ecosystem.

I started from the document:
https://cwiki.apache.org/confluence/display/CLOUDSTACK/Marvin+-+Testing+with+Python

To run simulator I have built docker image for 4.11:

docker build -t simulator:4.11 -f tools/docker/Dockerfile .

It has built correctly.

Next, I run the simulator:
docker run -it --rm -p 8080:8080 -p 8096:8096 simulator:411

It started well, I can login.

Next, I deployed DC as specified in document above:
python tools/marvin/marvin/deployDataCenter.py
<https://cwiki.apache.org/confluence/display/CLOUDSTACK/deployDataCenter.py>
 \
    -i setup/dev/advanced.cfg
<https://cwiki.apache.org/confluence/display/CLOUDSTACK/advanced.cfg>

Next, I run the suite:
$ export MARVIN_CONFIG=setup/dev/advanced.cfg
<https://cwiki.apache.org/confluence/display/CLOUDSTACK/advanced.cfg>
$ export TEST_SUITE=test/integration/smoke
$ export ZONE_NAME=Sandbox-simulator
$ nosetests-2.7 \
  --with-marvin \
  --marvin-config=${MARVIN_CONFIG} \
  -w ${TEST_SUITE} \
  --with-xunit \
  --xunit-file=/tmp/bvt_selfservice_cases.xml
<https://cwiki.apache.org/confluence/display/CLOUDSTACK/bvt_selfservice_cases.xml>
 \
  --zone=${ZONE_NAME} \
  --hypervisor=simulator \
  -a tags=advanced,required_hardware=false

What I see is that some tests fail, especially those, which connected with
OOB management.
I tried to do the same for basic zone with basic.cfg and also OOB tests
fail and some other as well.

Is it OK or I do something wrong?

Thanks a lot.


-- 
With best regards, Ivan Kudryavtsev
Bitworks LLC
Cell RU: +7-923-414-1515
Cell USA: +1-201-257-1512
WWW: http://bitworks.software/ <http://bw-sw.com/>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message