cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tutkowski, Mike" <Mike.Tutkow...@netapp.com>
Subject Re: [VOTE] Apache CloudStack 4.11.2.0 RC5
Date Wed, 14 Nov 2018 22:54:46 GMT
I should note that I’m running vSphere 5.5, by the way. I believe that’s still supported
in CS 4.11.

On 11/14/18, 3:52 PM, "Tutkowski, Mike" <Mike.Tutkowski@netapp.com> wrote:

    NetApp Security WARNING: This is an external email. Do not click links or open attachments
unless you recognize the sender and know the content is safe.
    
    
    
    
    The VR doesn’t show as having an IP address.
    
    On 11/14/18, 3:50 PM, "Paul Angus" <paul.angus@shapeblue.com> wrote:
    
        NetApp Security WARNING: This is an external email. Do not click links or open attachments
unless you recognize the sender and know the content is safe.
    
    
    
    
        Mgmt. server should ssh into VR.
        I'll fire a similar build in out lab.
    
    
        paul.angus@shapeblue.com
        www.shapeblue.com
        Amadeus House, Floral Street, London  WC2E 9DPUK
        @shapeblue
    
    
    
    
        -----Original Message-----
        From: Tutkowski, Mike <Mike.Tutkowski@netapp.com>
        Sent: 14 November 2018 22:41
        To: dev@cloudstack.apache.org; users@cloudstack.apache.org
        Subject: Re: [VOTE] Apache CloudStack 4.11.2.0 RC5
    
        Right, I’ve compiled and run with –Dnoredist. The SSVM and CPVM come up fine.
They both show the VM and agent running. The VR boots up. I can see it at the login prompt
in vSphere Client. I don’t see any obvious errors in cloud.log. Maybe a port is blocked
and it can’t talk to the management server?
    
        On 11/14/18, 3:10 PM, "Paul Angus" <paul.angus@shapeblue.com> wrote:
    
            NetApp Security WARNING: This is an external email. Do not click links or open
attachments unless you recognize the sender and know the content is safe.
    
    
    
    
            I've tested in an ubuntu16 basic zone but not vmware basic zone - I guess that
it goes without say that you know to use build nonoss from vmware... have you used the 6.5
sdk ?
            I think that it always says requires upgrade until the VR checks in.
            Have the SSVM and CPVM checked in ok?  If you go on the VR through the vCenter
console what do you see?
    
            paul.angus@shapeblue.com
            www.shapeblue.com
            Amadeus House, Floral Street, London  WC2E 9DPUK
            @shapeblue
    
    
    
    
            -----Original Message-----
            From: Tutkowski, Mike <Mike.Tutkowski@netapp.com>
            Sent: 14 November 2018 21:16
            To: dev@cloudstack.apache.org; users@cloudstack.apache.org
            Subject: Re: [VOTE] Apache CloudStack 4.11.2.0 RC5
    
            I’m having a hard time getting the VR with vSphere to come up successfully.
    
            I built the code from source (the specified commit) and am using the system VM
template specified in this e-mail chain.
    
            I’m running in a Basic Zone. When I look at the details for the VR in the GUI,
it says Requires Upgrade is Yes. When I click the button to upgrade the template, the operation
fails.
    
            Thoughts?
    
            On 11/13/18, 6:59 AM, "Paul Angus" <paul.angus@shapeblue.com> wrote:
    
                NetApp Security WARNING: This is an external email. Do not click links or
open attachments unless you recognize the sender and know the content is safe.
    
    
    
    
                Hi All,
    
                I've created a 4.11.2.0 release (RC5), with the following artefacts up for
testing and a vote:
    
    
                Git Branch and Commit SH:
                https://gitbox.apache.org/repos/asf?p=cloudstack.git;a=shortlog;h=refs/heads/4.11.2.0-RC20181113T0924
                Commit: 5aae410dfce2bef5cc21a0892370cb5d0628f681
    
                Source release (checksums and signatures are available at the same
                location):
                https://dist.apache.org/repos/dist/dev/cloudstack/4.11.2.0/
    
                PGP release keys (signed using 51EE0BC8):
                https://dist.apache.org/repos/dist/release/cloudstack/KEYS
    
                The vote will be open for 72 hours - until 14:00 GMT on Friday 16th Nov.
    
                For sanity in tallying the vote, can PMC members please be sure to indicate
"(binding)" with their vote?
    
                [ ] +1 approve
                [ ] +0 no opinion
                [ ] -1 disapprove (and reason why)
    
                Additional information:
    
                For users' convenience, I've built packages from 5aae410dfce2bef5cc21a0892370cb5d0628f681
and published RC5 repository here:
                http://packages.shapeblue.com/testing/41120rc5/
    
                The release notes are still work-in-progress, but the systemvm template upgrade
section has been updated.
    
                4.11.2.0 systemvm templates are available from here:
                http://packages.shapeblue.com/testing/systemvm/41120rc5/
    
                Only the following changes have been added to RC5:
    
                +-------------------------+----------+---------------+----------+------------------------------------------------------------+
                | Version                 | Github   | Type          | Priority | Description
                                               |
                +=========================+==========+===============+==========+============================================================+
                | 4.11.2.0                | `#3018`_ |               |          | Prevent
error on GroupAnswers on VR creation               |
                +-------------------------+----------+---------------+----------+------------------------------------------------------------+
                | 4.11.2.0                | `#3007`_ |               |          | Add missing
ConfigDrive entries on existing zones after    |
                |                         |          |               |          | upgrade
                                                   |
                +-------------------------+----------+---------------+----------+------------------------------------------------------------+
                | 4.11.2.0                | `#2980`_ |               |          | [4.11] Fix
set initial reservation on public IP ranges     |
                +-------------------------+----------+---------------+----------+------------------------------------------------------------+
                | 4.11.2.0                | `#3010`_ |               |          | Fix DirectNetworkGuru
canHandle checks for lowercase       |
                |                         |          |               |          | isolation
methods                                          |
                +-------------------------+----------+---------------+----------+------------------------------------------------------------+
    
                .. _`#3012`: https://github.com/apache/cloudstack/pull/3012
                .. _`#3018`: https://github.com/apache/cloudstack/pull/3018
                .. _`#3007`: https://github.com/apache/cloudstack/pull/3007
                .. _`#2980`: https://github.com/apache/cloudstack/pull/2980
                .. _`#3010`: https://github.com/apache/cloudstack/pull/3010
    
    
    
                Kind regards,
    
                Paul Angus
    
    
                paul.angus@shapeblue.com
                www.shapeblue.com
                Amadeus House, Floral Street, London  WC2E 9DPUK
                @shapeblue
    
    
    
    
    
    
    
    
    
    

Mime
View raw message