cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tutkowski, Mike" <>
Subject Re: Problem with CLOUDSTACK-10240 (Cannot migrate local volume to shared storage)
Date Mon, 16 Jul 2018 19:40:50 GMT
When I ran my suite of tests on 4.11.1, I did not encounter this issue. Also, looking at the
code now, it appears this new code is first in 4.12.

On 7/16/18, 1:36 PM, "Yiping Zhang" <> wrote:

    Is this code already in ACS 
    CLOUDSTACK-10240 is listed as fixed in, according to release note here,,
but in the JIRA ticket itself, the "fixed version/s" field says 4.12.
    We are using XenServer clusters with shared NFS storages and I am about to migrate to
ACS from  Since we move VM between clusters a lot, this is going to be a
blocker for us.  Someone please confirm.
    On 7/14/18, 11:20 PM, "Tutkowski, Mike" <> wrote:
        While running managed-storage regression tests tonight, I noticed a problem that is
not related to managed storage.
        CLOUDSTACK-10240 is a ticket asking that we allow the migration of a virtual disk
that’s on local storage to shared storage. In the process of enabling this feature, the
VirtualMachineManagerImpl.getPoolListForVolumesForMigration method was re-written in a way
that completely breaks at least one use case: Migrating a VM across compute clusters (at least
supported in XenServer). If, say, a virtual disk resides on shared storage in the source compute
cluster, we must be able to copy this virtual disk to shared storage in the destination compute
        As the code is currently written, this is no longer possible. It also seems that the
managed-storage logic has been dropped for some reason in the new implementation.
        Rafael – It seems that you worked on this feature. Would you be able to look into
this and create a PR?

View raw message