cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Angus <paul.an...@shapeblue.com>
Subject RE: KVM on ubuntu
Date Tue, 16 Jan 2018 09:22:46 GMT
Thanks guys,

😊 I guessed that you were meaning 14.04 Özhan.

@wido are you saying that you need the -l flag in '/etc/default/libvirt-bin' for live migration
or only in '/etc/init/libvirt-bin.conf'  ?


Kind regards,

Paul Angus

paul.angus@shapeblue.com 
www.shapeblue.com
53 Chandos Place, Covent Garden, London  WC2N 4HSUK
@shapeblue
  
 


-----Original Message-----
From: Özhan Rüzgar Karaman [mailto:oruzgarkaraman@gmail.com] 
Sent: 16 January 2018 09:05
Cc: dev@cloudstack.apache.org
Subject: Re: KVM on ubuntu

On Tue, Jan 16, 2018 at 10:49 AM, Wido den Hollander <wido@widodh.nl> wrote:

>
>
> On 01/16/2018 06:36 AM, Özhan Rüzgar Karaman wrote:
>
>> Hi Paul;
>> Ubuntu 16.04 has systemd installed and it directly controls libvirtd 
>> process so if you add -d to /etc/default/libvirt-bin file libvirtd 
>> tries to control to its self and then you have problem, you could not 
>> stop/start/restart libvirtd service via systemd. Only adding -l flag 
>> to libvirtd_opts is enough for Cloudstack.
>>
>> We also make no change on /etc/init/libvirt-bin.conf file for 16.04
>>
>>
I recheck my previous email and my written info below is for 14.04 (i mistakely wrote 16.04
for below info)

For Ubuntu 16.04 you need to add both -d and -l flags for
>> /etc/default/libvirt-bin
>> file.
>>
>>
> Indeed! Mainly the -l flag is important to make libvirtd listen on TCP 
> sockets which are required for live migration.
>
> Wido
>
>
> Thanks
>> Özhan
>>
>> On Mon, Jan 15, 2018 at 11:34 PM, Paul Angus 
>> <paul.angus@shapeblue.com>
>> wrote:
>>
>> Hey guys,
>>>
>>> I'm no Ubuntu Guru, so I want to check that I have this right....
>>>
>>> Our documentation says:
>>> --------------------------
>>> On Ubuntu: modify /etc/default/libvirt-bin Add "-l" to the following 
>>> line libvirtd_opts="-d"
>>> so it looks like:
>>> libvirtd_opts="-d -l"
>>> ---------------------------
>>>
>>> I've found on Ubuntu 16.04 that you seem to need:
>>> /etc/default/libvirt-bin
>>> to have:
>>> libvirtd_opts="-l"
>>>
>>> and
>>> /etc/init/libvirt-bin.conf
>>> to have:
>>> env libvirtd_opts="-d -l"
>>>
>>> Can anyone confirm/deny this and should it also be this way for 
>>> Ubuntu
>>> 14.04 ?
>>>
>>>
>>> If so I'll update the documentation...
>>>
>>>
>>> cheers
>>>
>>>
>>>
>>> Kind regards,
>>>
>>> Paul Angus
>>>
>>>
>>> paul.angus@shapeblue.com
>>> www.shapeblue.com
>>> 53 Chandos Place, Covent Garden, London  WC2N 4HSUK @shapeblue
>>>
>>>
>>>
>>>
>>>
>>
Mime
View raw message