cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frank Maximus <frank.maxi...@nuagenetworks.net>
Subject Re: 4.9 / 4.10 KVM + openvswitch + vpc + static nat / secondary ip on eth2?
Date Tue, 31 Oct 2017 19:35:36 GMT
I think that the bug you mentioned might not be related.
Could you please send the content of the file /etc/cloudstack/ips.json on
the VR.

That might provide useful information.

Kind regards,
Frank

On Tue, 31 Oct 2017 15:23 Vogel, Sven, <Sven.Vogel@kupper-computer.com>
wrote:

> Hi Devs,
>
> i have the following problem.
>
> When I look this jira ticket I see no solution.
> https://issues.apache.org/jira/browse/CLOUDSTACK-6801  but I think the
> problem is not solved correctly.
>
>     1. KVM
>     2. Bridges
>     bond with two interfaces and trunk (0,129,180,100-1500) to cloudbr0
>     Cloudbr0 (0 - guest network)
>     Fakebridge pub129 (public network)
>     Fakebridge sto180 (secondary storage network)
>     Fakebridge  mgmt0 (management)
>
>     If I have a vpc all things work until I add a secondary ip and add a
> static nat.
>
>     The following will happen, first address will be on the the correct
> interface 146.0.122.134/26 but static nat will be on the false network.
> Its on the eth2…
>
>     root@r-29-VM:~# ip a
>     1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
>         link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
>         inet 127.0.0.1/8 scope host lo
>     2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast
> state UP qlen 1000
>         link/ether 0e:00:a9:fe:03:81 brd ff:ff:ff:ff:ff:ff
>         inet 169.254.3.129/16 brd 169.254.255.255 scope global eth0
>     3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast
> state UP qlen 1000
>         link/ether 1e:00:2c:00:00:68 brd ff:ff:ff:ff:ff:ff
>         inet 146.0.122.134/26 brd 146.0.122.191 scope global eth1
>     4: eth2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast
> state UP qlen 1000
>         link/ether 02:00:57:07:00:0c brd ff:ff:ff:ff:ff:ff
>         inet 192.168.1.254/24 brd 192.168.1.255 scope global eth2
>         inet 146.0.122.135/26 brd 146.0.122.191 scope global eth2
>
> Normally I think the secondary ip should be on signed to eth1 not eth2! It
> sets my ip on the guest network vlan range on my cloudbr0 but it should be
> pub129. vnet6 has 1353 guest tag and not the public tag.
>
> [root@kvm01 ~]# ovs-vsctl list-br
> cloud0
> cloudbr0
> mgmt0
> pub129
> sto180
>
> [root@kvm01 ~]# virsh domiflist r-29-VM
> Interface  Type       Source     Model       MAC
> -------------------------------------------------------
> vnet4      bridge     cloud0     virtio      0e:00:a9:fe:03:81
> vnet5      bridge     pub129     virtio      1e:00:2c:00:00:68
> vnet6      bridge     cloudbr0   virtio      02:00:57:07:00:0c
>
>     Bridge "cloud0"
>         Port "vnet4"
>             Interface "vnet4"
>
>         Port "vnet5"
>             tag: 129
>             Interface "vnet5"
>         Port "vnet6"
>             tag: 1353
>             Interface "vnet6"
>
> Whats wrong or what can I do to fix this? I hope anybody has an idea.
>
>
> greetings
> Sven Vogel
> Head of Cloud Solutions / Consultants
> Kupper Computer GmbH
> Prager Str. 15
> 04103 Leipzig
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message