cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tutkowski, Mike" <Mike.Tutkow...@netapp.com>
Subject Re: Marvin Install Issue
Date Thu, 27 Jul 2017 06:21:28 GMT
Thanks, Jayapal!

> On Jul 26, 2017, at 11:22 PM, Jayapal Uradi <jayapal.uradi@accelerite.com> wrote:
> 
> Hi Mike,
> 
> Long back I got issue related to mysql-connector. I followed the below steps, see if
this helps for installing mysql-connector.
> 
> #mysql-connector-python
> http://stackoverflow.com/questions/31748278/how-do-you-install-mysql-connector-python-development-version-through-pip
> $  git clone https://github.com/mysql/mysql-connector-python.git
> $  cd mysql-connector-python
> $  python ./setup.py build
> $  sudo python ./setup.py install
> ...
>>>> import mysql.connector as msc
>>>> msc.__version__
> ‘2.1.3'
> 
> Thanks,
> Jayapal
> 
> On Jul 27, 2017, at 7:46 AM, Tutkowski, Mike <Mike.Tutkowski@netapp.com<mailto:Mike.Tutkowski@netapp.com>>
wrote:
> 
> Hi everyone,
> 
> I am having trouble installing Marvin on Ubuntu 14.04 from master.
> 
> It’s complaining that it’s having trouble with mysql-connector-python.
> 
> mtutkowski@mike-ubuntu:~/cloudstack/cloudstack$ sudo pip install --upgrade tools/marvin/dist/Marvin-*.tar.gz
> Unpacking ./tools/marvin/dist/Marvin-4.11.0.0-SNAPSHOT.tar.gz
> Running setup.py (path:/tmp/pip-5URDXT-build/setup.py) egg_info for package from file:///home/mtutkowski/cloudstack/cloudstack/tools/marvin/dist/Marvin-4.11.0.0-SNAPSHOT.tar.gz
>   /usr/local/lib/python2.7/dist-packages/setuptools/dist.py:340: UserWarning: The version
specified ('4.11.0.0-SNAPSHOT') is an invalid version, this may not work as expected with
newer versions of setuptools, pip, and PyPI. Please see PEP 440 for more details.
>     "details." % self.metadata.version
> 
>   warning: no files found matching '*.txt' under directory 'docs'
> Could not find any downloads that satisfy the requirement mysql-connector-python>=1.1.6
in /usr/lib/python2.7/dist-packages (from Marvin==4.11.0.0-SNAPSHOT)
> Downloading/unpacking mysql-connector-python>=1.1.6 (from Marvin==4.11.0.0-SNAPSHOT)
> Cleaning up...
> No distributions at all found for mysql-connector-python>=1.1.6 in /usr/lib/python2.7/dist-packages
(from Marvin==4.11.0.0-SNAPSHOT)
> Storing debug log for failure in /home/mtutkowski/.pip/pip.log
> 
> But it seems to be installed:
> 
> python-mysql.connector/trusty,now 1.1.6-1 all [installed]
> 
> Thoughts?
> 
> Thanks!
> Mike
> 
> DISCLAIMER
> ==========
> This e-mail may contain privileged and confidential information which is the property
of Accelerite, a Persistent Systems business. It is intended only for the use of the individual
or entity to which it is addressed. If you are not the intended recipient, you are not authorized
to read, retain, copy, print, distribute or use this message. If you have received this communication
in error, please notify the sender and delete all copies of this message. Accelerite, a Persistent
Systems business does not accept any liability for virus infected mails.
Mime
View raw message