cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rohit Yadav <rohit.ya...@shapeblue.com>
Subject Re: GSoC'17
Date Tue, 23 May 2017 08:27:09 GMT
Sachin,


I think you're trying to build deb packages. To do this on your Ubuntu16.04 based environment,
install the build dependencies as defined in the debian/control file (apt-get install them)

Build-Depends: debhelper (>= 9), openjdk-8-jdk | java8-sdk | java8-jdk | openjdk-7-jdk,
genisoimage,
 python-mysql.connector, maven (>= 3) | maven3, python (>= 2.7), lsb-release, dh-systemd


You may also consider to use a docker container image I had created for this purpose, we use
this container in all of the blueorangutan-trillian CI tests:

https://hub.docker.com/r/bhaisaab/ubuntu-cloudstack-slave/


Reference deb-pkg build script using above docker container: https://gist.github.com/rhtyd/57c5b904c1f25455126cbc6b1c0bb83f


Regards.

________________________________
From: sachin patil <sachin931350@gmail.com>
Sent: 22 May 2017 23:50:13
To: Syed Ahmed
Cc: dev
Subject: Re: GSoC'17

Hello,

Sry to be late. The output of the first command mvn install -P deps
https://drive.google.com/file/d/0B250zd28Pn8WWklXdVdHZGdyVzg/view?usp=sharing

output of second command dpkg-buildpackage

dpkg-buildpackage: source package cloudstack
dpkg-buildpackage: source version 4.10.0.0-SNAPSHOT
dpkg-buildpackage: source distribution unstable
dpkg-buildpackage: source changed by the Apache CloudStack project <
dev@cloudstack.apache.org>
dpkg-buildpackage: host architecture amd64
dpkg-source --before-build cloudstack
dpkg-checkbuilddeps: Unmet build dependencies: debhelper (>= 9)
python-mysql.connector dh-systemd
dpkg-buildpackage: warning: build dependencies/conflicts unsatisfied;
aborting
dpkg-buildpackage: warning: (Use -d flag to override.)

On Mon, May 22, 2017 at 11:47 PM, sachin patil <sachin931350@gmail.com>
wrote:

> Hello,
>
> Sry to be late. The output of the first command mvn install -P deps
> attached in the mail.
>
> output of second command dpkg-buildpackage
>
> dpkg-buildpackage: source package cloudstack
> dpkg-buildpackage: source version 4.10.0.0-SNAPSHOT
> dpkg-buildpackage: source distribution unstable
> dpkg-buildpackage: source changed by the Apache CloudStack project <
> dev@cloudstack.apache.org>
> dpkg-buildpackage: host architecture amd64
> dpkg-source --before-build cloudstack
> dpkg-checkbuilddeps: Unmet build dependencies: debhelper (>= 9)
> python-mysql.connector dh-systemd
> dpkg-buildpackage: warning: build dependencies/conflicts unsatisfied;
> aborting
> dpkg-buildpackage: warning: (Use -d flag to override.)
>
>
> On Mon, May 22, 2017 at 9:59 PM, sachin patil <sachin931350@gmail.com>
> wrote:
>
>> I am stuck in rain.
>> thanks for the info sir. will do all relevant checks and mail you in an
>> hour
>>
>> On 22-May-2017 9:55 PM, "Syed Ahmed" <sahmed@cloudops.com> wrote:
>>
>>> FYI, if you find the problem even with latest 4.9 agent. Try building
>>> the debs and install them on the host
>>>
>>> mvn install -P deps && dpkg-buildpackage
>>>
>>>
>>>
>>> On Mon, May 22, 2017 at 10:43 AM, Daan Hoogland <daan.hoogland@gmail.com
>>> > wrote:
>>>
>>>> On Mon, May 22, 2017 at 4:37 PM, sachin patil <sachin931350@gmail.com>
>>>> wrote:
>>>> >
>>>> >> > >>     According to the link you told me to enter in
acs.list in
>>>> source.d
>>>> >> > >> folder. Cloudstack-agent 4.9.2 is installed.  I build
CS
>>>> management
>>>> >> from
>>>> >> > >> code 4.10.0.0 snapshot.
>>>>
>>>>
>>>> You better have a look at this. Does the agent and the ms both support
>>>> (the same version of) that setup host params command? something might
>>>> have changed between 4.9.2 and 4.10 snapshot.
>>>>
>>>> --
>>>> Daan
>>>>
>>>
>>>
>

rohit.yadav@shapeblue.comĀ 
www.shapeblue.com
53 Chandos Place, Covent Garden, London  WC2N 4HSUK
@shapeblue
  
 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message