cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rohit Yadav <rohit.ya...@shapeblue.com>
Subject Re: F5 compile issue with 4.5.x
Date Wed, 05 Apr 2017 14:21:57 GMT
Mike, it seems issue with your axis dependency version. See and compare the axis and axis-jaxrpc
dependency version from master branch. Install the f5 dependency jars from here: https://github.com/rhtyd/cloudstack-nonoss
and while building ACS 4.5.x use JDK1.7.


Regards.

________________________________
From: Tutkowski, Mike <Mike.Tutkowski@netapp.com>
Sent: 05 April 2017 01:36:48
To: dev@cloudstack.apache.org
Subject: F5 compile issue with 4.5.x

Hi,

I see the following error now when trying to compile 4.5.x code:

[INFO] Compiling 12 source files to /Users/solidfire/Documents/CloudStack/CloudStack/plugins/network-elements/f5/target/classes
[INFO] -------------------------------------------------------------
[ERROR] COMPILATION ERROR :
[INFO] -------------------------------------------------------------
[ERROR] /Users/solidfire/Documents/CloudStack/CloudStack/plugins/network-elements/f5/src/com/cloud/network/resource/F5BigIpResource.java:[411,26]
error: cannot access Stub

I’ve not seen this “Stub” problem before.

Anyone familiar with what it’s referring to?

Thanks!
Mike

rohit.yadav@shapeblue.com 
www.shapeblue.com
53 Chandos Place, Covent Garden, London  WC2N 4HSUK
@shapeblue
  
 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message