cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Will Stevens <wstev...@cloudops.com>
Subject Re: Re:Re: Fw: [4.10] VPN disconnected while network changes taken
Date Thu, 27 Apr 2017 17:37:03 GMT
Hey Haijiao,
I believe I have fixed all the problems you have raised now with this PR:
https://github.com/apache/cloudstack/pull/2062

In this process I also fixed a couple other Remote Access VPN bugs which
were undesired.

Let me know if you have any other issues with this.

Cheers,

*Will STEVENS*
Lead Developer

<https://goo.gl/NYZ8KK>

On Wed, Apr 26, 2017 at 9:01 AM, Will Stevens <wstevens@cloudops.com> wrote:

> I will look into the VPN user issue. I did not look at that and it is a
> different code path. I need to be able to reconfigure the VPN legitimately,
> so I will see if I can reload while not touching the established
> connections. Thanks for testing, I should be able to look at this today to
> see if I can fix the remaining issue.
>
> On Apr 26, 2017 2:35 AM, "Haijiao" <18602198181@163.com> wrote:
>
>> Hi, Will
>>
>>
>>
>> We have tested this fix.  The remote VPN connection is now working fine
>> while network changes taken.
>>
>>
>> However, we noticed if we try to add/delete VPN accounts,  the connection
>> will be disconnected again.
>>
>>
>> It seems the issue is not completely fixed yet.
>>
>>
>> Regards,
>>
>>
>> 在2017年04月25 15时33分, "Haijiao"<18602198181@163.com>写道:
>>
>> Thanks Will,
>>
>>
>> will test this week.
>>
>>
>>
>>
>>
>>
>> 在2017年04月25 04时03分, "Will Stevens"<wstevens@cloudops.com>写道:
>>
>>
>> Here is the fix to this: https://github.com/apache/cloudstack/pull/2062
>>
>>
>> Will STEVENS
>>
>> Lead Developer
>>
>>
>>
>>
>>
>>
>> On Mon, Apr 24, 2017 at 11:34 AM, Haijiao <18602198181@163.com> wrote:
>>
>> Hi Will
>>
>> Any progress about this issue ?
>>
>> tks
>>
>>
>> Sent from my mobile
>>
>>
>>
>> --------- 转发的邮件 ---------
>>
>> 发件人:                Haijiao
>> 发送日期:                2017年04月14日 23:21
>> 收件人:                dev
>> 抄送人:
>> 主题:                Re:Re: [4.10] VPN disconnected while network changes
>> taken
>> Sure, Karuturi
>>
>>
>> Logged a bug in Jira,  thanks!
>>
>>
>> CLOUDSTACK-9878 Remote Access VPN that losing connection when new network
>> configs are introduced
>> https://issues.apache.org/jira/browse/CLOUDSTACK-9878
>>
>>
>>
>>
>>
>>
>> 在2017年04月14 13时14分, "Rajani Karuturi"<rajani@apache.org>写道:
>>
>> Hi Haijiao,
>>
>> Thanks for testing. Can you log a bug for this please? It can be
>> a blocker for 4.10.
>>
>> @Will,
>>
>> Did you get a chance to take a look at this issue?
>>
>> Thanks,
>>
>> ~ Rajani
>>
>> http://cloudplatform.accelerite.com/
>>
>> On April 12, 2017 at 7:12 AM, Will Stevens
>> (wstevens@cloudops.com) wrote:
>>
>> Thanks, I will have a look.
>>
>> *Will STEVENS*
>> Lead Developer
>>
>> <https://goo.gl/NYZ8KK>
>>
>> On Tue, Apr 11, 2017 at 8:58 PM, Haijiao <18602198181@163.com>
>> wrote:
>>
>> HI, Will
>> It's a Remote Access VPN that losing connection while new
>> network configs
>> introduced.
>> Thanks !
>>
>> 在2017年04月12 02时26分, "Will Stevens"<wstevens@cloudops.com>写道:
>>
>> Is this a Site-to-Site VPN connection or the Remote Access VPN
>> that is
>> losing connection when new network configs are introduced?
>>
>> Thanks,
>>
>> *Will STEVENS*
>> Lead Developer
>>
>> <https://goo.gl/NYZ8KK>
>>
>> On Sat, Apr 8, 2017 at 12:49 AM, Haijiao <18602198181@163.com>
>> wrote:
>>
>> Hi,
>>
>> We built and tested the ACS 4.10 from the latest master (Apr.7,
>> 2017)
>>
>> Our environment is,
>> - ACS: 4.10.0.0-SNAPSHOT
>> - Management Server: Centos7.2 1151
>> - Host: Centos7.2 1151
>> - System VM: systemvm64template-master-4.10.0-kvm.qcow2.bz2
>> - Network: Isolated Network
>> - Network Offering: Offering for Isolated networks with Source
>> Nat
>>
>> service
>>
>> enabled
>>
>> We can successfully setup VPN and it works as expected. However,
>> once
>>
>> we
>>
>> take any network changes below, the VPN connnection will be
>> immediately
>> disconnected.
>>
>> - Update firewall rules (add/change)
>> - Update port fowarding
>> - Update LB
>> - Add one more VPN account
>>
>> Is there some configuration we missed ? Or it's due to the new
>> VPN
>> component (StrongSWAN) introcuced in 4.10 ?
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message