cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Syed Ahmed <sah...@cloudops.com>
Subject Re: Need help in getting CentOS 7 templates to run on Cloudstack 4.9 and VMWare
Date Fri, 31 Mar 2017 11:58:21 GMT
Hey Nux,

It worked! Thanks for fixing this. I am able to ping the VM now.

On Fri, Mar 31, 2017 at 4:17 AM, Nux! <nux@li.nux.ro> wrote:
> Syed,
>
> I am aware of the renaming issue and avoid it, if you check my kickstart I specifically
add biosdevname=0 and net.ifnames=0
> http://jenkins.openvm.eu/cloudstack/config/centos/centos7-vmware.cfg
>
> However yesterday Rohit brought to my attention the ova generation script inserts a e1000
eth0 which apparently breaks things in certain situations.
> https://github.com/apache/cloudstack/pull/2022#issuecomment-290339928
>
> I corrected the script and built a new image here, please give it a try.
> http://jenkins.openvm.eu/cloudstack/centos/x86_64/centos-7-vmware.ova
>
> If the problem persists, can you go in single user mode and check the /proc/cmdline and
share it here?
>
> --
> Sent from the Delta quadrant using Borg technology!
>
> Nux!
> www.nux.ro
>
> ----- Original Message -----
>> From: "Syed Ahmed" <sahmed@cloudops.com>
>> To: "Nux!" <nux@li.nux.ro>
>> Cc: "dev" <dev@cloudstack.apache.org>
>> Sent: Thursday, 30 March, 2017 23:54:36
>> Subject: Re: Need help in getting CentOS 7 templates to run on Cloudstack 4.9 and
VMWare
>
>> I tried the one you provided however, it still has the same problem
>> ... DHCP doesn't seem to pick up. I also see that the interface is not
>> named eth0 .. could this be the problem? I can try changing the
>> network driver and see if that helps. Will report back.
>>
>> On Thu, Mar 30, 2017 at 6:21 PM, Nux! <nux@li.nux.ro> wrote:
>>> Hi, I am working on a new set of templates, you can try this one:
>>> http://jenkins.openvm.eu/cloudstack/centos/x86_64/centos-7-vmware.ova
>>>
>>> If still no luck, happy to debug if you can provide me an account. The only
>>> templates I (can) test are the KVM ones.
>>>
>>> The official templates from various distros will not work properly as they
>>> are openstack/aws focused.
>>>
>>>
>>>
>>>
>>> On 30 March 2017 22:41:05 BST, Syed Ahmed <sahmed@cloudops.com> wrote:
>>>>
>>>> osboxes also only has VMDK and not OVA. Cloudstack currently only
>>>> supports OVA for VMWare
>>>>
>>>> On Thu, Mar 30, 2017 at 5:34 PM, Syed Ahmed <sahmed@cloudops.com> wrote:
>>>>>
>>>>>  The official CentOS site does not build OVA for VMWare unfortunately.
>>>>>  I found something on osboxes. I am trying that.
>>>>>
>>>>>  http://pasteboard.co/PNdpMkn1C.png is the screenshot of the error btw
>>>>>
>>>>>  On Thu, Mar 30, 2017 at 5:30 PM, Syed Ahmed <sahmed@cloudops.com>
wrote:
>>>>>>
>>>>>>  I thought the centos images from the official site did not have
the
>>>>>>  cloudstack datasource. I'll try and report!
>>>>>>
>>>>>>  On Thu, Mar 30, 2017 at 5:26 PM, Pierre-Luc Dion <pdion@cloudops.com>
>>>>>> wrote:
>>>>>>>
>>>>>>>  Hi Syed, have you tried coud images from centos site, i think
centos
>>>>>>> build
>>>>>>>  cloudimage as canonical for ubuntu.
>>>>>>>
>>>>>>>
>>>>>>>  On Mar 30, 2017 5:24 PM, "Rafael Weingärtner"
>>>>>>> <rafaelweingartner@gmail.com>
>>>>>>>  wrote:
>>>>>>>
>>>>>>>>  Attachments are not forwarded with emails.
>>>>>>>>
>>>>>>>>  On Thu, Mar 30, 2017 at 5:16 PM, Syed Ahmed <sahmed@cloudops.com>
>>>>>>>> wrote:
>>>>>>>>
>>>>>>>>>  FYI I'm attaching the screenshot of the cloud-init error
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>  On Thu, Mar 30, 2017 at 5:14 PM, Syed Ahmed <sahmed@cloudops.com>
>>>>>>>>> wrote:
>>>>>>>>>>
>>>>>>>>>>  Hi All,
>>>>>>>>>>
>>>>>>>>>>  I'm trying to run a CentOS 7 template on VMWare
and ACS 4.9 but
>>>>>>>>>>  somehow cloud-init doesn't seem to pick up the IP
form the VR. The
>>>>>>>>>>  default template which is bundled with ACS (CentOS
5) works.
>>>>>>>>>>
>>>>>>>>>>  I got the CentOS7 template from
>>>>>>>>>>  http://dl.openvm.eu/cloudstack/centos/vanilla/7/
>>>>>>>>
>>>>>>>>  x86_64/CentOS-7-x86_64-
>>>>>>>>>
>>>>>>>>>  vanilla-vmware.ova
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>  Is there any setting that I need to do for this
template? Are there
>>>>>>>>>>  any other places I can get a working template for
CentOS7 for
>>>>>>>>>>  Cloudstack?
>>>>>>>>>>
>>>>>>>>>>  Thanks,
>>>>>>>>>>  -Syed
>>>>>>>>>
>>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>  --
>>>>>>>>  Rafael Weingärtner
>>>>>>>
>>>>>>>
>>>
>>> --
>> > Sent from my Android device with K-9 Mail. Please excuse my brevity.

Mime
View raw message