cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tutkowski, Mike" <Mike.Tutkow...@netapp.com>
Subject Re: Can't create a zone using master
Date Wed, 15 Feb 2017 01:27:15 GMT
If it helps in debugging, I typically assign 10.117.40.20 - 10.117.40.25 for Management IPs
and 10.117.40.26 - 10.117.40.99 for Guest IPs.

On the network in my lab, I am assigned the following range (by our IT people):

10.117.40.0 /25 (10.117.40.0 - 10.117.40.127)

Subnet Mask: 255.255.255.128
Gateway: 10.117.40.126

This worked fine up until I rebased against master recently.

Thanks!
Mike

On 2/14/17, 6:20 PM, "Tutkowski, Mike" <Mike.Tutkowski@netapp.com> wrote:

    Also, for any CloudStack networking person out there who is curious about this, I see
the following in cloud.log for my SSVM:
    
    Wed Feb 15 01:07:50 UTC 2017 Incompleted parameters STORAGE_IP:, STORAGE_NETMASK:, STORAGE_CIDR:.
Cannot setup storage network
    Wed Feb 15 01:07:50 UTC 2017 Not setting up route of RFC1918 space to 10.117.40.126 befause
10.117.40.93 is RFC1918.
    
    On 2/14/17, 6:14 PM, "Tutkowski, Mike" <Mike.Tutkowski@netapp.com> wrote:
    
        I’m not very familiar with the networking code that’s failing, but I worked around
it with these changes:
        
        https://github.com/mike-tutkowski/cloudstack/commit/834b7ea7df18f278cbc9eb1bfaa9578fad2debeb
        
        I’m not sure if those are viable changes in this case, but perhaps someone who works
in the networking area of CloudStack can say.
        
        The problem now, however (and maybe this is unrelated), is that neither my CPVM nor
my SSVM report their agent as Running.
        
        Those system VMs do show as each having public, private, and link local IP addresses
(as well as an IP address for their gateway).
        
        Is anyone else having these kinds of issues with recent master code?
        
        Thanks!
        Mike
        
        On 2/14/17, 3:02 PM, "Tutkowski, Mike" <Mike.Tutkowski@netapp.com> wrote:
        
            By the way, this is for a Basic Zone.
            
            On 2/14/17, 2:44 PM, "Tutkowski, Mike" <Mike.Tutkowski@netapp.com> wrote:
            
                Hi,
                
                I’m getting a NullPointerException when trying to create a zone using master.
                
                Below is the relevant code in ConfigurationManagerImpl.
                
                In the else block, network.getCidr() returns null and NetUtil.getCidrNetmask
then throws a NullPointerException.
                
                I noticed that network.getGateway() also returns null (which seems odd).
                
                Thoughts on this?
                
                Thanks!
                Mike
                
                public Pair<Boolean, Pair<String, String>> validateIpRange(final
String startIP, final String endIP, final String newVlanGateway, final String newVlanNetmask,
final List<VlanVO> vlans, final boolean ipv4,
                        final boolean ipv6, String ip6Gateway, String ip6Cidr, final String
startIPv6, final String endIPv6, final Network network) {
                    String vlanGateway = null;
                    String vlanNetmask = null;
                    boolean sameSubnet = false;
                    if (CollectionUtils.isNotEmpty(vlans)) {
                        for (final VlanVO vlan : vlans) {
                            vlanGateway = vlan.getVlanGateway();
                            vlanNetmask = vlan.getVlanNetmask();
                            sameSubnet = hasSameSubnet(ipv4, vlanGateway, vlanNetmask, newVlanGateway,
newVlanNetmask, startIP, endIP,
                                    ipv6, ip6Gateway, ip6Cidr, startIPv6, endIPv6, network);
                            if (sameSubnet) break;
                        }
                    } else {
                        vlanGateway = network.getGateway();
                        vlanNetmask = NetUtils.getCidrNetmask(network.getCidr());
                
                
            
            
        
        
    
    

Mime
View raw message