cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ustcweizhou <...@git.apache.org>
Subject [GitHub] cloudstack pull request #1916: CLOUDSTACK-9462: Build packages on Ubuntu 12....
Date Tue, 24 Jan 2017 09:55:56 GMT
GitHub user ustcweizhou opened a pull request:

    https://github.com/apache/cloudstack/pull/1916

    CLOUDSTACK-9462: Build packages on Ubuntu 12.04/16.04 and support tomcat6/tomcat7

    Changes
    (1) seperate debian/control and debian/rules for Ubuntu 12.04/16.04
    (2) add python-setuptools in Build-Depends
    (3) seperate cloudstack-management.service and cloudstack-management.default for CentOS7
and Ubuntu 16.04
    (4) add server7-ssl.xml and server7-nonssl.xml in management installation
    (5) link /usr/share/cloudstack-management/lib and /usr/share/cloudstack-management/bin
to correct path (tomcat6 or tomcat7)
    (6) link /etc/cloudstack/management/server.xml to correct file path (server-nonssl.xml
or server7-nonssl.xml)
    (7) remove *.zip from .gitignore to avoid build error caused by missing /vhds/test.vhd.zip
    
    Instruction
    (1) build packages on Ubuntu 12.04/16.04: packaging/build_deb.sh
        Output on Ubuntu 12.04: cloudstack-management_4.9.3.0-SNAPSHOT~precise_all.deb
        Output on Ubuntu 16.04: cloudstack-management_4.9.3.0-SNAPSHOT~xenial_all.deb
    (2) setup tomcat6/tomcat7 on management server: cloudstack-setup-management --tomcat7
    
    Already tested on Ubuntu 12.04 and Ubuntu 16.04, upgraded from 4.7.1 to 4.9.3.0-SNAPSHOT

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/ustcweizhou/cloudstack 4.9-systemd-tomcat7

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/cloudstack/pull/1916.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #1916
    
----
commit fba99e534fcc967bf32461b08f1ccd9d91db8201
Author: Wei Zhou <w.zhou@tech.leaseweb.com>
Date:   2017-01-24T09:34:21Z

    CLOUDSTACK-9462: Build packages on Ubuntu 12.04/16.04 and support tomcat6/tomcat7
    
    Changes
    (1) seperate debian/control and debian/rules for Ubuntu 12.04/16.04
    (2) add python-setuptools in Build-Depends
    (3) seperate cloudstack-management.service and cloudstack-management.default for CentOS7
and Ubuntu 16.04
    (4) add server7-ssl.xml and server7-nonssl.xml in management installation
    (5) link /usr/share/cloudstack-management/lib and /usr/share/cloudstack-management/bin
to correct path (tomcat6 or tomcat7)
    (6) link /etc/cloudstack/management/server.xml to correct file path (server-nonssl.xml
or server7-nonssl.xml)
    (7) remove *.zip from .gitignore to avoid build error caused by missing /vhds/test.vhd.zip
    
    Instruction
    (1) build packages on Ubuntu 12.04/16.04: packaging/build_deb.sh
        Output on Ubuntu 12.04: cloudstack-management_4.9.3.0-SNAPSHOT~precise_all.deb
        Output on Ubuntu 16.04: cloudstack-management_4.9.3.0-SNAPSHOT~xenial_all.deb
    (2) setup tomcat6/tomcat7 on management server: cloudstack-setup-management --tomcat7
    
    Already tested on Ubuntu 12.04 and Ubuntu 16.04, upgraded from 4.7.1 to 4.9.3.0-SNAPSHOT

----


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message