cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simon Weller <swel...@ena.com>
Subject Re: Volumes created without HyperVisor specified
Date Wed, 18 Jan 2017 19:05:14 GMT
Thomas,


What version did you upgrade from?


________________________________
From: Thomas Moroder <cloudstack@server24.eu>
Sent: Wednesday, January 18, 2017 1:00 PM
To: dev@cloudstack.apache.org
Subject: Volumes created without HyperVisor specified

Dear CloudStack dev-team,

after upgrading a CloudStack installation to version 4.9.2 new volumes are
created without HyperVisor specified. This happens when creating from the UI, as
well as by using CloudMonkey/the API:

###
(local) ?? > create volume name="testdisk2"
diskofferingid=30fa0e20-47c7-40ad-92c9-c2b775e8d536
zoneid=f563b3fc-2428-4414-9e58-0505ef11f8bf

accountid = 90e8a863-ec61-11e5-bb13-bb66cccd9eae
cmd = org.apache.cloudstack.api.command.admin.volume.CreateVolumeCmdByAdmin
created = 2017-01-18T19:52:00+0100
jobid = 5d544187-abcb-4a16-9b42-879aaae3fb25
jobinstanceid = 37e1c2b6-7138-4572-879f-c9243433882b
jobinstancetype = Volume
jobprocstatus = 0
jobresult:
volume:
id = 37e1c2b6-7138-4572-879f-c9243433882b
name = testdisk2
account = admin
created = 2017-01-18T19:52:00+0100
destroyed = False
diskofferingdisplaytext = Small Disk, 5 GB
diskofferingid = 30fa0e20-47c7-40ad-92c9-c2b775e8d536
diskofferingname = Small
displayvolume = True
domain = ROOT
domainid = 3c7c4ae5-ec61-11e5-bb13-bb66cccd9eae
hypervisor = None
isextractable = True
jobid = 5d544187-abcb-4a16-9b42-879aaae3fb25
jobstatus = 0
provisioningtype = thin
quiescevm = False
size = 5368709120
state = Allocated
storagetype = shared
tags:
type = DATADISK
zoneid = f563b3fc-2428-4414-9e58-0505ef11f8bf
zonename = PrivateCloud_AdvancedZone1
jobresultcode = 0
jobresulttype = object
jobstatus = 1
userid = 76f8889a-1b88-44a9-bab8-0951190c1dd9
###

In the specific case it should use KVM as the HyperVisor.

No error message is found in the logs or the hosts/agents/SSVM, I am available
for further debugging.

Of course it is not possible to attach this volume to a VM thereafter (AFAIK
volumes are hypervisor-specific).

Any input or help would be greatly appreciated.

Sincerely,
Thomas Moroder

--
Incubatec GmbH - Srl
Via Scurcia'str. 36, 39046 Ortisei(BZ), ITALIA
Registered with the chamber of commerce of Bolzano the 8th of November 2001 with
REA-No. 168204 (s.c. of EUR 10.000 f.p.u.)
President: Thomas Moroder, VAT-No. IT 02283140214
Tel: +39.0471796829 - Fax: +39.0471797949

IMPRINT:
http://www.incubatec.com/imprint.html
PRIVACY:
http://www.server24.it/informativa_completa.html


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message