cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From swill <...@git.apache.org>
Subject [GitHub] cloudstack issue #1888: CLOUDSTACK-9710: Switch to JRE1.8
Date Fri, 13 Jan 2017 21:33:38 GMT
Github user swill commented on the issue:

    https://github.com/apache/cloudstack/pull/1888
  
    BTW, something that is worth noting is that even if you use a new system vm template,
but the box that the vm template was built on is running Java 7, you will get the same error
that @syed just reported.  I forgot to update my Jenkins slave to use Java 8 and I was able
to reproduce the problem that @syed experienced with new builds of the system vm template.
 Maybe we should try to put a check or something if you try to build the system vm template
with the wrong version.  I am sure people will run into this because almost everyone will
be using Java 7 in their Jenkins for previous ACS builds and I am sure others will forget
to make the change to use Java 8 for those builds.  
    
    Building the ACS RPMs will fail if you don't have Java 8 installed, but the system VM
build will succeed even though the resulting template will not be functional...


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message