cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rhtyd <...@git.apache.org>
Subject [GitHub] cloudstack issue #1888: CLOUDSTACK-9710: Switch to JRE1.8
Date Thu, 05 Jan 2017 06:09:55 GMT
Github user rhtyd commented on the issue:

    https://github.com/apache/cloudstack/pull/1888
  
    This one is open for review, pinging for review -- @swill @karuturi @abhinandanprateek
@murali-reddy @PaulAngus @nvazquez @serg38 @milamberspace @wido @syed @mike-tutkowski and
others
    
    High level major changes:
    - Switches to openjdk 8 for building CloudStack.
    - Switches to openjdk-8-jre for running mgmt server, usage server, agents. Test results
are based on CentOS6, CentOS7 against Xen, VMware and KVM.
    - A new systemvmtemplate with openjdk-8 (zulu-8 distribution of openjdk from Azul as Debian7
repos don't have openjdk-8-jre) needs to be used. A compatible 4.6.0 systemvmtemplate was
built and tested, that only replaces openjdk-7 JRE with openjdk-8 JRE and was found to be
compatible with ACS 4.6.0+. If StrongSwan PR is merged, we'll need to create and use a new
systemvmtemplate with 4.10+.


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message