cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rohit Yadav <rohit.ya...@shapeblue.com>
Subject Re: [VOTE] Apache Cloudstack 4.9.1.0 (RC1)
Date Thu, 15 Dec 2016 06:53:54 GMT
All,


Please proceed with testing this RC. I've kicked new tests to rule out intermittent failures.



Hi Bobby,


I've tried to deploy a 4.5.2.2 based environment and upgraded to 4.9.1.0 without any upgrade
failures. I'm using MySQL 5.7, can you share your MySQL server version and other environment
details?


To make 4.5.2.2 work with MySQL 5.7, I had to make a minor change:

--- a/engine/schema/src/com/cloud/upgrade/dao/Upgrade410to420.java
+++ b/engine/schema/src/com/cloud/upgrade/dao/Upgrade410to420.java
@@ -1568,7 +1568,7 @@ public class Upgrade410to420 implements DbUpgrade {
                 s_logger.debug("Index already exists on host_details - not adding new one");
             } else {
                 // add the index
-                PreparedStatement pstmtUpdate = conn.prepareStatement("ALTER IGNORE TABLE
`cloud`.`host_details` ADD INDEX `fk_host_details__host_id` (`host_id`)");
+                PreparedStatement pstmtUpdate = conn.prepareStatement("ALTER TABLE `cloud`.`host_details`
ADD INDEX `fk_host_details__host_id` (`host_id`)");
                 pstmtUpdate.executeUpdate();
                 s_logger.debug("Index did not exist on host_details -  added new one");
                 pstmtUpdate.close();




Reference logs:


INFO  [o.a.c.s.l.CloudStackExtendedLifeCycle] (main:null) (logid:) Running system integrity
checker com.cloud.upgrade.DatabaseUpgradeChecker@5109880a
INFO  [c.c.u.DatabaseUpgradeChecker] (main:null) (logid:) Grabbing lock to check for database
upgrade.
INFO  [c.c.u.DatabaseUpgradeChecker] (main:null) (logid:) DB version = 4.5.2 Code Version
= 4.9.1.0
INFO  [c.c.u.DatabaseUpgradeChecker] (main:null) (logid:) Database upgrade must be performed
from 4.5.2 to 4.9.1.0
WARN  [c.c.u.d.Upgrade452to460] (main:null) (logid:) 4.6.0KVM SystemVm template not found.
KVM hypervisor is not used, so not failing upgrade
WARN  [c.c.u.d.Upgrade452to460] (main:null) (logid:) 4.6.0Ovm3 SystemVm template not found.
Ovm3 hypervisor is not used, so not failing upgrade
WARN  [c.c.u.d.Upgrade452to460] (main:null) (logid:) 4.6.0Hyperv SystemVm template not found.
Hyperv hypervisor is not used, so not failing upgrade
WARN  [c.c.u.d.Upgrade452to460] (main:null) (logid:) 4.6.0XenServer SystemVm template not
found. XenServer hypervisor is not used, so not failing upgrade
WARN  [c.c.u.d.Upgrade452to460] (main:null) (logid:) 4.6.0LXC SystemVm template not found.
LXC hypervisor is not used, so not failing upgrade
WARN  [c.c.u.d.Upgrade452to460] (main:null) (logid:) 4.6.0VMware SystemVm template not found.
VMware hypervisor is not used, so not failing upgrade
INFO  [c.c.u.d.Upgrade461to470] (main:null) (logid:) Altered cloud_usage.cloud_usage table
and added column quota_calculated
ERROR [c.c.u.PropertiesUtil] (main:null) (logid:) Unable to find properties file: commands.properties
INFO  [c.c.u.DatabaseUpgradeChecker] (main:null) (logid:) Cleaning upgrades because all management
server are now at the same version
INFO  [c.c.u.DatabaseUpgradeChecker] (main:null) (logid:) Cleanup upgrade Upgrade452to460
to upgrade from 4.5.2-4.6.0 to 4.6.0
INFO  [c.c.u.DatabaseUpgradeChecker] (main:null) (logid:) Cleanup upgrade Upgrade460to461
to upgrade from 4.6.0-4.6.1 to 4.6.1
INFO  [c.c.u.DatabaseUpgradeChecker] (main:null) (logid:) Cleanup upgrade Upgrade461to470
to upgrade from 4.6.1-4.7.0 to 4.7.0
INFO  [c.c.u.DatabaseUpgradeChecker] (main:null) (logid:) Cleanup upgrade Upgrade470to471
to upgrade from 4.7.0-4.7.1 to 4.7.1
INFO  [c.c.u.DatabaseUpgradeChecker] (main:null) (logid:) Cleanup upgrade Upgrade471to480
to upgrade from 4.7.1-4.8.0 to 4.8.0
INFO  [c.c.u.DatabaseUpgradeChecker] (main:null) (logid:) Cleanup upgrade Upgrade480to481
to upgrade from 4.8.0-4.8.1 to 4.8.1
INFO  [c.c.u.DatabaseUpgradeChecker] (main:null) (logid:) Cleanup upgrade Upgrade481to490
to upgrade from 4.8.1-4.9.0 to 4.9.0
INFO  [c.c.u.DatabaseUpgradeChecker] (main:null) (logid:) Cleanup upgrade Upgrade490to4910
to upgrade from 4.9.0-4.9.1.0 to 4.9.1.0


Regards.

________________________________
From: Boris Stoyanov <boris.stoyanov@shapeblue.com>
Sent: 14 December 2016 18:01:53
To: dev@cloudstack.apache.org
Subject: Re: [VOTE] Apache Cloudstack 4.9.1.0 (RC1)

Hi,

We’ve currently have a plan for upgrade testing covering the following scenarios:
I’ve tried upgrading from 4.5.2.2 to 4.9.1, but got the following exception:

2016-12-13 14:37:28,128 DEBUG [c.c.u.d.ScriptRunner] (main:null) (logid:) --
2016-12-13 14:37:28,128 DEBUG [c.c.u.d.ScriptRunner] (main:null) (logid:) -- Schema upgrade
from 4.5.1 to 4.6.0
2016-12-13 14:37:28,128 DEBUG [c.c.u.d.ScriptRunner] (main:null) (logid:) --
2016-12-13 14:37:28,128 DEBUG [c.c.u.d.ScriptRunner] (main:null) (logid:) ALTER TABLE `cloud`.`snapshots`
ADD COLUMN `min_iops` bigint(20) unsigned COMMENT 'Minimum IOPS'
2016-12-13 14:37:28,135 ERROR [c.c.u.d.ScriptRunner] (main:null) (logid:) Error executing:
ALTER TABLE `cloud`.`snapshots` ADD COLUMN `min_iops` bigint(20) unsigned COMMENT 'Minimum
IOPS'
2016-12-13 14:37:28,135 ERROR [c.c.u.d.ScriptRunner] (main:null) (logid:) com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException:
Duplicate column name 'min_iops'
2016-12-13 14:37:28,136 ERROR [c.c.u.DatabaseUpgradeChecker] (main:null) (logid:) Unable to
execute upgrade script: /usr/share/cloudstack-management/setup/db/schema-452to460.sql
com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Duplicate column name 'min_iops'
        at com.cloud.utils.db.ScriptRunner.runScript(ScriptRunner.java:185)
        at com.cloud.utils.db.ScriptRunner.runScript(ScriptRunner.java:87)

We’re currently having a plan to cover upgrade testing to 4.9.1 from 4.3, 4.5.2.2, 4.6.0.
I’d love to continue with testing these upgrade scenarios once we fix the issue.

Currently also we’re executing component tests against the following combinations:

[KVM]
MS CentOS68 + KVM hosts CentOS68
MS CentOS72 + KVM hosts CentOS72

[VMware]
MS CentOS68 + VMware55u3
MS CentOS68 + VMware60u2
MS CentOS68 + VMware65

MS CentOS72 + VMware55u3
MS CentOS72 + VMware60u2
MS CentOS72 + VMware65

[XenServer]
MS CentOS68 + XenServer62sp1
MS CentOS68 + XenServer65sp1

MS CentOS72+ XenServer65sp1

*Once we get 4.9.1 we’re looking fw to test XenServer 7 as well, as part of 4.9.2.0


Smoke tests has passed on KVM, VMware and XenServer hosts with CentOS6 and CentOS7 MS.

Thanks,


boris.stoyanov@shapeblue.com
www.shapeblue.com<http://www.shapeblue.com>
53 Chandos Place, Covent Garden, London  WC2N 4HSUK
@shapeblue




rohit.yadav@shapeblue.com 
www.shapeblue.com
53 Chandos Place, Covent Garden, London  WC2N 4HSUK
@shapeblue
  
 

> On Dec 14, 2016, at 12:18 PM, Murali Reddy <muralimmreddy@gmail.com> wrote:
>
> +1
>
> Based on smoke test results [1] and below tests run manually on VMware deployment
>
>  - VM life cycle operations
>  - network life cycle operations
>  - verified source NAT, static NAT, PF, LB, VPC internal LB, network ACL, firewall
>  - upgrade from 4.9 and 4.5.2
>
>
> IMO issue raised by Milamber should be fixed on 4.10. If the functionality does not exist
in 4.9, then no need to have schema change in 4.8 to 4.9 upgrade path.
>
> Redundant VPC VR functionality appears to be broken from last few releases. In my testing
noticed both the VR getting stuck in backup or in unknown state. RVR test failed consistently
in smoke tests [1]. We should at least release note them as known issues. I will check existing
bugs and open new one if necessary.
>
> [1] https://github.com/apache/cloudstack/pull/1753
>
>
>
>
> On 14/12/16, 12:32 AM, "Milamber" <milamber@apache.org> wrote:
>
>>
>> Hello,
>>
>> I'm not sure, but perhaps we have an 'indirect' blocker for 4.9.1.0 RC1.
>>
>> Currently the upgrade from 4.9.1.0 RC1 to 4.10.0.0 SNAPSHOT don't works
>> because the schema-481to490.sql in the 4.9.1.0 / 4.9 doesn't contains
>> the commit of CLOUDSTACK-9438 (2e77496601ab5420723ce8b955b3960faaba7d5c).
>> (this commit is currently in master)
>>
>> When you try to make the upgrade you have this error: "Unknown column
>> 'image_store_details.display' in 'field list'"
>> see:  https://issues.apache.org/jira/browse/CLOUDSTACK-9671
>>
>> Currently there have 2 diff between the schema-481to490.sql in 4.9.1.0
>> RC1 (and 4.9 branch) and master branch.
>>
>> What is your opinion: blocker or not?
>>
>> Just copy the 2 sql request inside the schema-4910to41000.sql file (but
>> the commit 2e77496601ab5420723ce8b955b3960faaba7d5c contains other
>> modified files)?
>>
>> Milamber
>>
>>
>>
>> $ diff ./setup/db/db/schema-481to490.sql /tmp/MASTER-schema-481to490.sql
>> 547a548,552
>>>
>>> ALTER TABLE `cloud`.`image_store_details` CHANGE COLUMN `value`
>> `value` VARCHAR(255) NULL DEFAULT NULL COMMENT 'value of the detail',
>> ADD COLUMN `display` tinyint(1) NOT
>>> NULL DEFAULT '1' COMMENT 'True if the detail can be displayed to the
>> end user' AFTER `value`;
>>>
>>> ALTER TABLE `snapshots` ADD COLUMN `location_type` VARCHAR(32)
>> COMMENT 'Location of snapshot (ex. Primary)';
>>
>>
>>
>>
>>
>> On 12/12/2016 21:36, Milamber wrote:
>>> Hello,
>>>
>>> My vote +1 (binding)
>>>
>>> Tests are passed on a virtual topology of servers  (CS over CS)
>>> (1mgr+2nodes+1nfs) :
>>>
>>> 1/ Fresh install of 4.9.1.0 RC1 (adv net) on Ubuntu 14.04.5 + KVM +
>>> NFS : OK
>>> Some standard tests with success (create vm, migration, HA, create
>>> networks, create user, create ssh key, destroy vm, register template,
>>> create snapshot, restore snapshot, create template, ip association, ip
>>> release, static nat, firewall rule)
>>> Some tests with cloudstack ansible module with success too (create
>>> network, register templates, create vm, ip, firewall rule)
>>>
>>> 2/ Test upgrade from 4.8.1 to 4.9.1.0 RC1 : OK
>>>
>>> 3/ Test upgrade from 4.8.2 RC1 to 4.9.1.0 RC1 : don't works (expected)
>>>
>>> 4/ Tests of all localization Web UI for 4.9.1.0 RC1:
>>> Localization works well except Spanish (not a blocker to release): the
>>> Web UI display partially the localization strings due of one bad
>>> carriage return in the label
>>> message.installWizard.copy.whatIsCloudStack string (from Transifex).
>>> This is the same issue that the 4.8.2 RC1.
>>>
>>>
>>> Perhaps add in the Release notes this Spanish l10n issue.
>>>
>>> Thanks to the RM.
>>>
>>> Milamber
>>>
>>>
>>>
>>> On 10/12/2016 03:11, Rohit Yadav wrote:
>>>> Hi All,
>>>>
>>>> I've created a 4.9.1.0 release, with the following artifacts up for a
>>>> vote:
>>>>
>>>> Git Branch and Commit SH:
>>>> https://git-wip-us.apache.org/repos/asf?p=cloudstack.git;a=shortlog;h=refs/heads/4.9.1.0-RC20161210T0838
>>>>
>>>> Commit: af2679959b634d095b93b8265c6da294d360065d
>>>>
>>>> List of changes:
>>>> https://git-wip-us.apache.org/repos/asf?p=cloudstack.git;a=blob_plain;f=CHANGES;hb=4.9.1.0-RC20161210T0838
>>>>
>>>>
>>>> Source release (checksums and signatures are available at the same
>>>> location):
>>>> https://dist.apache.org/repos/dist/dev/cloudstack/4.9.1.0/
>>>>
>>>> PGP release keys (signed using 0EE3D884):
>>>> https://dist.apache.org/repos/dist/release/cloudstack/KEYS
>>>>
>>>> Vote will be open for 120 hours, considering the process started
>>>> during the
>>>> weekends, and will end on 14 Dec 2016 end of the day.
>>>>
>>>> For sanity in tallying the vote, can PMC members please be sure to
>>>> indicate
>>>> "(binding)" with their vote?
>>>>
>>>> [ ] +1  approve
>>>> [ ] +0  no opinion
>>>> [ ] -1  disapprove (and reason why)
>>>>
>>>> Regards.
>>>>
>>>
>>>
>>
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message