cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wido den Hollander <w...@widodh.nl>
Subject Re: [DISCUSS][FUTURE] Move to JDK1.8 and support JRE1.8
Date Tue, 27 Dec 2016 12:25:21 GMT

> Op 27 december 2016 om 8:23 schreef Rohit Yadav <rohit.yadav@shapeblue.com>:
> 
> 
> All,
> 
> 
> Java7 has eol-ed, it's about time to move to Java8 for both codebase and runtime [1].
> 
> 
> An experimental PR [2] shows that moving to Java8 is fairly straight forward. The only
component that is failing is F5 network plugin, which lacks authors/maintainers as this issue
has been previously raised on dev@ [3].
> 
> 
> In order to move to JDK8, we'll need to take hard decisions to comment/exclude plugins
such as F5 from the default build profiles that may not get fixes and improvements from their
authors/maintainers. Thoughts, comments?
> 

I think that we should drop the F5 plugin then and move to Java 8. We can't stick on 7 for
ever imho.

Wido

> 
> [1] https://issues.apache.org/jira/browse/CLOUDSTACK-9710
> 
> <https://issues.apache.org/jira/browse/CLOUDSTACK-9710>
> 
> [2] https://github.com/apache/cloudstack/pull/1864
> 
> [3] http://markmail.org/message/ggx5ycoezyr2ywel
> 
> 
> Regards.
> 
> rohit.yadav@shapeblue.com 
> www.shapeblue.com
> 53 Chandos Place, Covent Garden, London  WC2N 4HSUK
> @shapeblue
>   
>  
>

Mime
View raw message