cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cloud List <cloud-l...@sg.or.id>
Subject Re: ACS - Some VMs unable to get DHCP IP from VR
Date Thu, 10 Nov 2016 12:07:55 GMT
Hi Wei,

Thanks for your reply.

You are right, when I tried to access the other subnet IP on port 80, it
got connection refused. I have modified the Apache configuration to add the
port and virtualhost configuration and we are now able to access the other
subnet IP on port 80.

root@test-40g-root-disk:~# telnet X.X.203.2 80
Trying X.X.203.2...
Connected to X.X.203.2.
Escape character is '^]'.
^]
telnet> quit
Connection closed.

However, password reset still doesn't work. Not too sure what's wrong.

I looked at the python script on /opt/cloud/bin/passwd_server_ip.py, it
seems to be looking into just one file called
/var/cache/cloud/passwords-X.X.202.2 although I see some IPs from other
subnets as well inside the file. Is there something we need to modify on
the area as well?

Any further advice is greatly appreciated.

Thank you.


On Thu, Nov 10, 2016 at 7:46 PM, Wei ZHOU <ustcweizhou@gmail.com> wrote:

> The password server  in VR is implemented by apache2.
> you can have a look at configuration files in /etc/apache2/ (ports.conf,
> sites-available/default, etc)
>
> you will notice that the server listens at the 80 port of default IP of VR.
> However, the VM in non-default ip subnets cannot reach the default IP.
>
> you need to create another configuration file in /etc/apache2/conf.d/ to
> support password servers on non-default ip subnets.
>
> -Wei
>
> 2016-11-10 12:23 GMT+01:00 Cloud List <cloud-list@sg.or.id>:
>
> > Hi Wei,
> >
> > In this case, dhcp works, and the server is up and running. But password
> > reset doesn't work. What could be the reason?
> >
> > Thanks.
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message