cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wei ZHOU <ustcweiz...@gmail.com>
Subject Re: ACS - Some VMs unable to get DHCP IP from VR
Date Thu, 10 Nov 2016 13:28:14 GMT
Sorry what I said in previous reply is wrong. The 80 port /apache2 are used
for ssh-key server, not password server.

For password server, there should be a passwd_server_ip.py running with
corresponding ip.
The password server will listen the 8080 port, and cache the vm password in
/var/cache/cloud/passwords-X.X.X.X

In a word, you need to run the following command:
/bin/bash /opt/cloud/bin/passwd_server_ip X.X.203.2 (the vr ip in second ip
subnet)

-Wei

2016-11-10 13:07 GMT+01:00 Cloud List <cloud-list@sg.or.id>:

> Hi Wei,
>
> Thanks for your reply.
>
> You are right, when I tried to access the other subnet IP on port 80, it
> got connection refused. I have modified the Apache configuration to add the
> port and virtualhost configuration and we are now able to access the other
> subnet IP on port 80.
>
> root@test-40g-root-disk:~# telnet X.X.203.2 80
> Trying X.X.203.2...
> Connected to X.X.203.2.
> Escape character is '^]'.
> ^]
> telnet> quit
> Connection closed.
>
> However, password reset still doesn't work. Not too sure what's wrong.
>
> I looked at the python script on /opt/cloud/bin/passwd_server_ip.py, it
> seems to be looking into just one file called
> /var/cache/cloud/passwords-X.X.202.2 although I see some IPs from other
> subnets as well inside the file. Is there something we need to modify on
> the area as well?
>
> Any further advice is greatly appreciated.
>
> Thank you.
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message