cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rhtyd <...@git.apache.org>
Subject [GitHub] cloudstack pull request #1647: CLOUDSTACK-9462: Systemd support for Ubuntu 1...
Date Fri, 19 Aug 2016 09:09:44 GMT
GitHub user rhtyd opened a pull request:

    https://github.com/apache/cloudstack/pull/1647

    CLOUDSTACK-9462: Systemd support for Ubuntu 16.04

    Created this based on @wido 's origin PR #1541 .
    
    Requesting for review and testing -- @jburwell @karuturi @wido @vincentbernat 
    @wido I think this change only brings systemd support to agent and usage packages, or
does cloudstack-management pkg has systemd support too?
    
    @blueorangutan package
    
    - systemd: Add a /etc/sysconfig/cloudstack-* file
    
      This allows users to easily override variables passed to Java when
      starting up.
    
      It also creates a foundation for sharing the systemd service profile
      between CentOS and Ubuntu since it only requires the environment file
      to be changed.
    
    - deb: Drop Ubuntu 12.04 support
    
      The libvirt and Qemu versions (1.2.2 and 2.0) in Ubuntu 12.04 are
      to old to support for CloudStack going forward.
    
      Ubuntu 14.04 and 16.04 provide the support required to provide new
      features and more stability.
    
    - deb: Add Ubuntu 16.04 support
    
      Ubuntu 16.04 differs from Ubuntu 14.04 in a few ways:
      - systemd instead of sysvinit / upstart
      - Java 8 support
    
      The packaging now detects on which distribution it is being
      build and based on that it installs different files in the
      packages, but it also changes the Dependencies.

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/apache/cloudstack 4.9-systemdubuntupkging

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/cloudstack/pull/1647.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #1647
    
----
commit a6defab4b2df923c07be63c584a5b84be8926f7d
Author: Wido den Hollander <wido@widodh.nl>
Date:   2016-04-28T18:59:30Z

    CLOUDSTACK-9462: Systemd support for Ubuntu 16.04
    
    - systemd: Add a /etc/sysconfig/cloudstack-* file
    
      This allows users to easily override variables passed to Java when
      starting up.
    
      It also creates a foundation for sharing the systemd service profile
      between CentOS and Ubuntu since it only requires the environment file
      to be changed.
    
    - deb: Drop Ubuntu 12.04 support
    
      The libvirt and Qemu versions (1.2.2 and 2.0) in Ubuntu 12.04 are
      to old to support for CloudStack going forward.
    
      Ubuntu 14.04 and 16.04 provide the support required to provide new
      features and more stability.
    
    - deb: Add Ubuntu 16.04 support
    
      Ubuntu 16.04 differs from Ubuntu 14.04 in a few ways:
      - systemd instead of sysvinit / upstart
      - Java 8 support
    
      The packaging now detects on which distribution it is being
      build and based on that it installs different files in the
      packages, but it also changes the Dependencies.
    
      Packages for Ubuntu 16.04 will require Java 8 as a JRE
    
    Signed-off-by: Rohit Yadav <rohit.yadav@shapeblue.com>

----


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message