cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rafaelweingartner <>
Subject [GitHub] cloudstack issue #1605: CLOUDSTACK-9428: Fix for CLOUDSTACK-9211 - Improve p...
Date Tue, 23 Aug 2016 17:46:32 GMT
Github user rafaelweingartner commented on the issue:
    Very nice proposal this one. I have only very small suggestions, which are the following:
    * The method “videoCardConfig”, would be better if called “configureVideoCard”,
normally I treat methods as actions, and as such, they normally start with a verb. This is
cosmetics, but I think it helps to follow the code.
    * Method “modifyVmVideoCardVRamSize” does not need that throws Exception.
    * Would you mind creating a test case for “modifyVmVideoCardVRamSize”, it is a very
simple integration test case.  It is pretty easy to do with mocks, if you need any help, just
send me an email.
    * If you remove the “throws exception from modifyVmVideoCardVRamSize”, you can also
remove from “setNewVRamSizeVmVideoCard”.
    * Would you mind creating test cases for the method “setNewVRamSizeVmVideoCard”?
    * Method “videoCardConfig”, if you removed the “throw Exception” from the above
methods, you can remove the “Catch Exception from here”
    * And also, what about  test cases for the method “videoCardConfig”?
    * What about changing the verb of “configSpecVideoCardNewVRamSize” method to its complete
form “configure”?
    * And finally, what about a test case for “configSpecVideoCardNewVRamSize”?
    @nvazquez great work, my suggestions are mostly aesthetics, but I think they can help
improve this PR.

If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at or file a JIRA ticket
with INFRA.

View raw message