cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jburwell <...@git.apache.org>
Subject [GitHub] cloudstack issue #1638: CLOUDSTACK-9456: Use Spring 4 and Java 8
Date Tue, 16 Aug 2016 19:06:29 GMT
Github user jburwell commented on the issue:

    https://github.com/apache/cloudstack/pull/1638
  
    @rhtyd @pdion891 I apologize for my delayed reply as I am on vacation ATM.  We had previously
agreed not to require Java8 until 5.0.0 which is scheduled for the end of 2016.  4.x should
be able to run on Java7 and Java8.  Furthermore, Spring4 does not require Java8 so I don't
see why such a Java upgrade would conflated with a Spring upgrade.
    
    @rhytd I think it makes sense to reduce scope of this PR to Soring only.  In a separate
PR, we can address running tests for 4.x on both Java7 and Java8 which needs to be done for
LTS as well.  Does that make sense?


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message