cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Angus <paul.an...@shapeblue.com>
Subject RE: 4.9+ release
Date Tue, 14 Jun 2016 18:02:44 GMT
+1 Daan.

My recollection was that major version number changes were only to be triggered by breaks
in backward compatibility (API).


Kind regards,

Paul Angus

paul.angus@shapeblue.comĀ 
www.shapeblue.com
53 Chandos Place, Covent Garden, London  WC2N 4HSUK
@shapeblue



-----Original Message-----
From: Daan Hoogland [mailto:daan.hoogland@gmail.com] 
Sent: 14 June 2016 14:47
To: dev <dev@cloudstack.apache.org>
Cc: Rajani Karuturi <rajani@apache.org>
Subject: Re: 4.9+ release

You know that would require more then one byte for our minor version, Will.
I would be very pleased to go to 5.0 before that time.

On Tue, Jun 14, 2016 at 3:43 PM, Will Stevens <wstevens@cloudops.com> wrote:

> Daan is just trying to get us to version 4.256.  :P
>
> *Will STEVENS*
> Lead Developer
>
> *CloudOps* *| *Cloud Solutions Experts
> 420 rue Guy *|* Montreal *|* Quebec *|* H3J 1S6 w cloudops.com *|* tw 
> @CloudOps_
>
> On Tue, Jun 14, 2016 at 9:41 AM, Daan Hoogland 
> <daan.hoogland@gmail.com>
> wrote:
>
> > -1 to what Wido said. None of those points warant a major release 
> > number upgrade. these should all be in 4.10, -.11, -12 etc.
> >
> > major incompatibilities like API refactor, dropping backend support 
> > for this or that hyporvisor or DB refactor are the things that 
> > warrant 5.0, IMNSHO
> >
> > On Tue, Jun 14, 2016 at 1:13 PM, Will Stevens 
> > <williamstevens@gmail.com>
> > wrote:
> >
> > > +1. :)
> > > On Jun 14, 2016 5:07 AM, "Wido den Hollander" <wido@widodh.nl> wrote:
> > >
> > > >
> > > > > Op 14 juni 2016 om 10:55 schreef Rajani Karuturi <
> rajani@apache.org
> > >:
> > > > >
> > > > >
> > > > > 4.10 or 5.0?
> > > > >
> > > >
> > > > I would say 4.10
> > > >
> > > > > We are in the 4.* release cycle from a long time.
> > > > > Just wanted to check if anyone is planning on major changes 
> > > > > which
> > > > warrants
> > > > > 5.0
> > > > >
> > > >
> > > > 5.0 should imho be:
> > > >
> > > > - Java 8
> > > > - Ubuntu 16.04 / systemd support
> > > > - Drop support for older libvirt versions (KVM)
> > > > - Some killer feature(s)
> > > >
> > > > Wido
> > > >
> > > > > ~Rajani
> > > >
> > >
> >
> >
> >
> > --
> > Daan
> >
>



--
Daan
Mime
View raw message