cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nux! <...@li.nux.ro>
Subject Re: Failing to enable SSL/HTTPS on console proxy vm
Date Thu, 16 Jun 2016 16:19:03 GMT
Dammit, I was missing the consoleproxy.url.domain! What an idiot ...
Works just fine now.

Will, it can be done, don't give up! :)

Thanks Andy!

Lucian

--
Sent from the Delta quadrant using Borg technology!

Nux!
www.nux.ro

----- Original Message -----
> From: "Andy Dills" <andy@xecu.net>
> To: users@cloudstack.apache.org
> Cc: dev@cloudstack.apache.org
> Sent: Thursday, 16 June, 2016 17:10:55
> Subject: Re: Failing to enable SSL/HTTPS on console proxy vm

> I have this working perfectly.
> 
> Couple of key things that are not mentioned in the
> documentation:
> 
> - You need to set consoleproxy.url.domain to *.domain.com for whatever domain
> you're using. Do this before re-uploading your SSL certificate. The SSL upload
> dialogue doesn't set this value as it should.
> 
> - You need a wildcard certificate for that domain.
> 
> Assuming you setup the proper DNS records, it should then work.
> 
> I'm open to follow up questions if anybody is struggling with this.
> 
> Thanks,
> Andy
> 
> Sent from my iPhone
> 
>> On Jun 16, 2016, at 12:01 PM, Will Stevens <wstevens@cloudops.com> wrote:
>> 
>> We have been having issues with this for as long as I can remember (on both
>> ACS and CCP).  In order to get it to work you have to 'trust unsafe
>> scripts' or whatever by clicking the shield in the URL bar in the top right
>> (maybe that is chrome).
>> 
>> I don't know that there is a solution, but if there is, I am all ears...
>> 
>> *Will STEVENS*
>> Lead Developer
>> 
>> *CloudOps* *| *Cloud Solutions Experts
>> 420 rue Guy *|* Montreal *|* Quebec *|* H3J 1S6
>> w cloudops.com *|* tw @CloudOps_
>> 
>>> On Thu, Jun 16, 2016 at 11:54 AM, Nux! <nux@li.nux.ro> wrote:
>>> 
>>> Hi,
>>> 
>>> Is there any particular voodoo involved in getting the $subject to work
>>> correctly on 4.8.0?
>>> I've uploaded the Comodo wildcard cabundle, crt and key in the
>>> Infrastructure page, the systemvms have rebooted.
>>> They came back fine and nothing dodgy in the logs, but when I open the
>>> console of a VM Firefox will say there are insecure contents loaded and
>>> will not display the terminal ajax thingy.
>>> View source shoes an iframe linking http://1.2.3.4 instead of
>>> https://1-2-3-4.wildcarddomain.tld.
>>> 
>>> Apache HTTPD and Tomcat had no issues with these certs.
>>> 
>>> Is there something that I am missing?
>>> 
>>> Thanks
>>> 
>>> 
>>> --
>>> Sent from the Delta quadrant using Borg technology!
>>> 
>>> Nux!
>>> www.nux.ro

Mime
View raw message