cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrei Mikhailovsky <and...@arhont.com>
Subject Re: Pesky volume snapshot schedule
Date Fri, 05 Feb 2016 09:54:13 GMT
Hi Anshul,

Many thanks for the suggestion. I will try that right away.

Cheers

Andrei



----- Original Message -----
> From: "Anshul Gangwar" <anshul.gangwar@citrix.com>
> To: "dev" <dev@cloudstack.apache.org>
> Sent: Friday, 5 February, 2016 09:40:49
> Subject: Re: Pesky volume snapshot schedule

> Try setting "volume.snapshot.job.cancel.threshold" value greater than
> "backup.snapshot.wait" value. This will make sure that backup snapshot is
> cancelled before job cancellation. This in turn will take care of cleanup of
> old snapshots.
> 
> Regards,
> Anshul
> 
> On 05-Feb-2016, at 2:53 PM, Andrei Mikhailovsky
> <andrei@arhont.com<mailto:andrei@arhont.com>> wrote:
> 
> Hello,
> 
> I was hoping someone could help me investigate and fix the issue that I am
> having with one of the volume snapshots schedules. I am running ACS version
> 4.6.2 on Ubuntu 14.04 with latest updates, etc.
> 
> I've got a 200 gig vm root disk image which I am snapshotting on a daily basis.
> I've created the schedule to take a snapshot at 9:30pm every day and keeping 8
> snapshots. The schedule is executing and the image is being snapshotted and
> placed on the nfs secondary storage. However, ACS does not remove the old
> snapshots at all and I am ending up with dozens and dozens of snapshots of this
> particular volume. I have to manually remove them to keep the secondary storage
> from filling up. The problem is with this particular volume. I've got several
> other daily snapshots schedules which are working perfectly well and their
> clean up works well as well.
> 
> I've compared db values for this particular volume with other volumes and I
> can't find any difference apart from the disk size. The db values for the
> schedule are also correct and look similar to a properly working schedule
> (apart from the start time). I've also tried to remove the schedule and create
> a new one at no avail.
> 
> Could someone help me fix the issue?
> 
> Many thanks
> 
> Andrei

Mime
View raw message