cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik Weber <terbol...@gmail.com>
Subject Re: [4.7] account table does NOT have AUTO_INCREMENT set for id
Date Fri, 08 Jan 2016 13:54:10 GMT
On Fri, Jan 8, 2016 at 2:31 PM, Wido den Hollander <wido@widodh.nl> wrote:

> Hi,
>
> I've been investigating a issue with a freshly installed 4.7 CloudStack
> setup and I was wondering if somebody else has seen this.
>
> The table account was looking like this:
>
> account | CREATE TABLE `account` (
>   `id` bigint(20) unsigned NOT NULL,
>   `account_name` varchar(100) DEFAULT NULL COMMENT 'an account name set
> by the creator of the account, defaults to username for single accounts',
>   `uuid` varchar(40) DEFAULT NULL,
>   `type` int(1) unsigned NOT NULL,
>   `domain_id` bigint(20) unsigned DEFAULT NULL,
>   `state` varchar(10) NOT NULL DEFAULT 'enabled',
>   `removed` datetime DEFAULT NULL COMMENT 'date removed',
>   `cleanup_needed` tinyint(1) NOT NULL DEFAULT '0',
>   `network_domain` varchar(100) DEFAULT NULL COMMENT 'Network domain
> name of the Vms of the account',
>   `default_zone_id` bigint(20) unsigned DEFAULT NULL,
>   `default` int(1) unsigned NOT NULL DEFAULT '0' COMMENT '1 if account
> is default',
>   PRIMARY KEY (`id`),
>   UNIQUE KEY `uc_account__uuid` (`uuid`),
>   KEY `i_account__removed` (`removed`)
> ) ENGINE=InnoDB DEFAULT CHARSET=utf8;
>
> The most important part is that the ID is lacking the AUTO_INCREMENT
> flag which caused new account creations to fail.
>
> I've been trying to track this back to where it was modified, but so far
> I haven't been able to find this.
>
> In non of our SQL files I can actually see the account table being created.
>

Definition seems to be in setup/db/create-schema.sql (approx line 1319 in
master).


>
> Has anybody seen this before?
>
> Wido
>


-- 
Erik

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message