cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jburwell <...@git.apache.org>
Subject [GitHub] cloudstack pull request: [4.9+] WIP: Support Java 8, Maven 3.3, Up...
Date Wed, 27 Jan 2016 10:04:09 GMT
Github user jburwell commented on the pull request:

    https://github.com/apache/cloudstack/pull/1370#issuecomment-175523813
  
    @bhaisaab if we make the packaging require Java 1.8, then users will be automatically
upgraded -- defeating the purpose of the deprecation.  It seems like an appropriate first
step is to audit all dependencies for Java8 support, and upgrade all affected dependencies.
 For example, we need to upgrade to Spring 4 because (Spring 3 does not support Java 8)[http://spring.io/blog/2013/05/21/spring-framework-4-0-m1-3-2-3-available/].
 In my opinion, we should perform the dependency upgrades as part of 4.9.


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message