cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jayapalu <...@git.apache.org>
Subject [GitHub] cloudstack pull request: Strongswan vpn feature
Date Wed, 09 Dec 2015 03:59:23 GMT
Github user jayapalu commented on a diff in the pull request:

    https://github.com/apache/cloudstack/pull/872#discussion_r47049123
  
    --- Diff: systemvm/patches/debian/vpn/etc/ipsec.d/l2tp.conf ---
    @@ -30,4 +35,5 @@ conn L2TP-PSK
             # ----------------------------------------------------------
             # Change 'ignore' to 'add' to enable this configuration.
             #
    +        rightsubnetwithin=10.1.2.0/8
    --- End diff --
    
    Default is 10.1.2.0/8. In configure.py 'configure_l2tpIpsec' method will update its value.
    
     We have only ip range ex:10.1.2.2-10.1.2.8 we don't have the cidr in DB. In global setting
we have option to configure only range not the cidr. We have to derive the cidr from the range
and it may not be correct some times.  
    If we hard code to /24  it may will be problem if the range crossing the /24. 
    If we introduce the global setting to configure the cidr, it is mess for the backward
compatibility.


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message