cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Илья Толстихин <inosi...@gmail.com>
Subject Re: DevCloud deployment
Date Mon, 16 Nov 2015 11:14:15 GMT
Thanks.

2015-11-16 10:28 GMT+06:00 Rajani Karuturi <rajani@apache.org>:

> I find it easier to use devcloud4[1]. It the easiest way for xen6.2
> devcloud setup.
> The documentation is also good. Just install the required tools/IP configs
> mentioned in README [2]. Then, go to the advanced and follow the readme[3]
> there for a advanced zone setup.
>
> [1] https://github.com/apache/cloudstack/tree/master/tools/devcloud4
> [2]
> https://github.com/apache/cloudstack/blob/master/tools/devcloud4/README.md
> [3]
>
> https://github.com/apache/cloudstack/blob/master/tools/devcloud4/advanced/README.md
>
> ~Rajani
>
> On Fri, Nov 13, 2015 at 12:52 PM, Daan Hoogland <daan.hoogland@gmail.com>
> wrote:
>
> > From your log it seems the host can be reached but doesn't respond s
> > expected. First guess :wrong version of vhd-utils?
> >
> > Sorry for the late reaction. Stuck in traffic
> >
> > Biligual auto correct use.  Read at your own risico
> > Op 12-nov.-2015 10:28 schreef "Илья Толстихин" <inosinum@gmail.com>:
> >
> > > This is fragment of vmops.log file of MS.
> > >
> > > 2015-11-12 0:49 GMT+06:00 Daan Hoogland <daan.hoogland@gmail.com>:
> > >
> > >> Ilya, Can you share the log of your management server? There must be
> > some
> > >> more info in there. And maybe you can check SRLog on the host To see
> if
> > >> anything happened there at all.
> > >>
> > >> On Wed, Nov 11, 2015 at 6:43 PM, Илья Толстихин <inosinum@gmail.com>
> > >> wrote:
> > >>
> > >> > Yes, this is Xen.
> > >> >
> > >> > 2015-11-11 22:00 GMT+06:00 Daan Hoogland <daan.hoogland@gmail.com>:
> > >> >
> > >> > > this is a xen host, right?
> > >> > >
> > >> > > On Wed, Nov 11, 2015 at 3:43 PM, Илья Толстихин
<
> inosinum@gmail.com
> > >
> > >> > > wrote:
> > >> > >
> > >> > > > On host ssh is up with 22 port only.
> > >> > > >
> > >> > > > 2015-11-11 20:03 GMT+06:00 Илья Толстихин <inosinum@gmail.com>:
> > >> > > >
> > >> > > > > Cloudstack 4.6.0
> > >> > > > > Yes, I can ssh to host
> > >> > > > >
> > >> > > > > 2015-11-11 19:41 GMT+06:00 Daan Hoogland <
> > daan.hoogland@gmail.com
> > >> >:
> > >> > > > >
> > >> > > > >> what version of ACS?
> > >> > > > >> It sounds like a network issue between ms and host?
can you
> ssh
> > >> from
> > >> > > ms
> > >> > > > to
> > >> > > > >> host on the right port? (i think it was 3922, might
be 3022)
> > >> > > > >>
> > >> > > > >> On Wed, Nov 11, 2015 at 1:42 PM, Илья Толстихин
<
> > >> inosinum@gmail.com
> > >> > >
> > >> > > > >> wrote:
> > >> > > > >>
> > >> > > > >> > Hi all,
> > >> > > > >> > Could you please help with the DevCloud deployment.
> > >> > > > >> >
> > >> > > > >> > I imported devcloud into virtualbox, in settings
*enabled
> > PAE*
> > >> and
> > >> > > > >> > created *host-only
> > >> > > > >> > network 192.168.56.1/24 <http://192.168.56.1/24>*
> > >> > > > >> > Devcloud is pinged now.
> > >> > > > >> >
> > >> > > > >> > I built and run cloudstack on my local machine
with
> commands
> > >> > > > >> > *mvn -Pdeveloper,systemvm clean install*
> > >> > > > >> > *mvn -Pdeveloper -pl developer,tools/devcloud
-Ddeploydb*
> > >> > > > >> > *mvn -pl :cloud-client-ui jetty:run*
> > >> > > > >> >
> > >> > > > >> >
> > >> > > > >> > Then I installed marvin and tried to deploy
datacenter with
> > >> > command
> > >> > > > >> > *mvn -P developer -pl tools/devcloud -Ddeploysvr*
> > >> > > > >> > and got exception
> > >> > > > >> >
> > >> > > > >> > *==== Deploy DC Started ====*
> > >> > > > >> > *Exception Occurred :['Traceback (most recent
call
> > last):\n', '
> > >> > > File
> > >> > > > >> > "../marvin/marvin/deployDataCenter.py", line
136, in
> > addHosts\n
> > >> > > > ret =
> > >> > > > >> > self.__apiClient.addHost(hostcmd)\n', '  File
> > >> > > > >> >
> > >> > > > >> >
> > >> > > > >>
> > >> > > >
> > >> > >
> > >> >
> > >>
> >
> "/usr/local/lib/python2.7/dist-packages/Marvin-4.6.0_SNAPSHOT-py2.7.egg/marvin/cloudstackAPI/cloudstackAPIClient.py",
> > >> > > > >> > line 1572, in addHost\n    response =
> > >> > > > >> > self.connection.marvinRequest(command,
> > response_type=response,
> > >> > > > >> > method=method)\n', '  File
> > >> > > > >> >
> > >> > > > >> >
> > >> > > > >>
> > >> > > >
> > >> > >
> > >> >
> > >>
> >
> "/usr/local/lib/python2.7/dist-packages/Marvin-4.6.0_SNAPSHOT-py2.7.egg/marvin/cloudstackConnection.py",
> > >> > > > >> > line 379, in marvinRequest\n    raise e\n',
> > >> > 'CloudstackAPIException:
> > >> > > > >> > Execute cmd: addhost failed, due to: errorCode:
530,
> > >> > > errorText:Cannot
> > >> > > > >> > transit agent status with event AgentDisconnected
for host
> 1,
> > >> > > > mangement
> > >> > > > >> > server id is 18413734744879,Unable to transition
to a new
> > state
> > >> > from
> > >> > > > >> > Creating via AgentDisconnected\n']*
> > >> > > > >> >
> > >> > > > >> > *===deploy dc failed, so cleaning the created
entries===*
> > >> > > > >> >
> > >> > > > >> > *====DeployDC: CleanUp Started====*
> > >> > > > >> >
> > >> > > > >> > *====Clean Up Entries=== {'Network':
> > >> > > > >> > [u'5720be8d-f8eb-4dee-af4f-9551409c8722'],
'Zone':
> > >> > > > >> > [u'd05cb102-2766-4d59-a94b-0998842b3717'],
> 'PhysicalNetwork':
> > >> > > > >> > [u'd641f7e3-0996-4064-a6ce-54620c0524e2'],
'Cluster':
> > >> > > > >> > [u'eb213a95-4b5b-4a7d-9b4d-be1754a3b932'],
'Pod':
> > >> > > > >> > [u'659bc864-4d10-48c9-83ef-30ee40f1ce8d'],
'order':
> > ['Cluster',
> > >> > > 'Pod',
> > >> > > > >> > 'Network', 'PhysicalNetwork', 'Zone']}*
> > >> > > > >> >
> > >> > > > >> > *===Removing DataCenter Failed===*
> > >> > > > >> >
> > >> > > > >> > As a result in cloudstack were created zone,
cluster, pod,
> > and
> > >> a
> > >> > > host
> > >> > > > >> with
> > >> > > > >> > state "Alert".
> > >> > > > >> >
> > >> > > > >> > Also I run
> > >> > > > >> > *python tools/marvin/marvin/deployDataCenter.py
-i
> > >> > > > >> > tools/devcloud/devcloud.cfg*
> > >> > > > >> > that gave same result.
> > >> > > > >> >
> > >> > > > >> > What am I doing wrong?
> > >> > > > >> >
> > >> > > > >>
> > >> > > > >>
> > >> > > > >>
> > >> > > > >> --
> > >> > > > >> Daan
> > >> > > > >>
> > >> > > > >
> > >> > > > >
> > >> > > >
> > >> > >
> > >> > >
> > >> > >
> > >> > > --
> > >> > > Daan
> > >> > >
> > >> >
> > >>
> > >>
> > >>
> > >> --
> > >> Daan
> > >>
> > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message