cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wilder Rodrigues <WRodrig...@schubergphilis.com>
Subject Re: [VOTE] Apache CloudStack 4.6.0 (round 2)
Date Wed, 11 Nov 2015 14:00:30 GMT
Nice to know, Lucian!

Happy testing! :)

Cheers,
Wilder


On 11 Nov 2015, at 14:46, Nux! <nux@li.nux.ro<mailto:nux@li.nux.ro>> wrote:

Wilder,

Thanks for that, adding systemvm-kvm-4.5 solved the problem.
I will do more testing, but the main issue is sorted.

--
Sent from the Delta quadrant using Borg technology!

Nux!
www.nux.ro<http://www.nux.ro/>

----- Original Message -----
From: "Wilder Rodrigues" <WRodrigues@schubergphilis.com<mailto:WRodrigues@schubergphilis.com>>
To: dev@cloudstack.apache.org<mailto:dev@cloudstack.apache.org>
Sent: Wednesday, 11 November, 2015 12:39:25
Subject: Re: [VOTE] Apache CloudStack 4.6.0 (round 2)

Hi Nux,

Concerning your second comment:

2 - after upgrading the packages to 4.6.0, the mgmt server complains the 4.5
systemvm is missing - wtf?

We explained how the upgrade is done in the issue ==>
https://issues.apache.org/jira/browse/CLOUDSTACK-9046

The current way ACS does the upgrade requires one to follow all the path. So,
going from 4.4.x to 4.6.x requires an upgrade to 4.5.x first. In order to avoid
that, you have to register a SystemVM template 4.5.x before as well. That’s how
I did that and how I have tested. All in the issue above. So, the second point
doesn’t really block the RC.

Now, about your first point, since you already mentioned how to get it working,
I wouldn’t say that’s a blocker, right?

Given the current state of the upgrade path, or how it is implemented, perhaps
the issue you created should be marked either “won’t fix” or be changed into an
improvement.

Cheers,
Wilder


On 11 Nov 2015, at 13:11, Nux! <nux@li.nux.ro<mailto:nux@li.nux.ro><mailto:nux@li.nux.ro>>
wrote:

-1

I'm testing upgrade from 4.4.1 (what we run in production) to 4.6.0 and have hit
2 issues.

1 - minor packaging issue, upgrading to 4.6.0 makes cloudstack-awsapi-4.4.1
complain about missing deps; rpm -e --nodeps cloudstack-awsapi gets rid of the
problem, perhaps there's a better way to obsolete this package

2 - after upgrading the packages to 4.6.0, the mgmt server complains the 4.5
systemvm is missing - wtf?
opened https://issues.apache.org/jira/browse/CLOUDSTACK-9056 for this with more
info

Lucian

--
Sent from the Delta quadrant using Borg technology!

Nux!
www.nux.ro<http://www.nux.ro/><http://www.nux.ro<http://www.nux.ro/>>

----- Original Message -----
From: "Remi Bergsma" <RBergsma@schubergphilis.com>
To: dev@cloudstack.apache.org
Sent: Tuesday, 10 November, 2015 15:03:03
Subject: [VOTE] Apache CloudStack 4.6.0 (round 2)

Hi all,

I've created a 4.6.0 release candidate, with the following artifacts up for a
vote:

Git Branch and Commit SH:
https://git-wip-us.apache.org/repos/asf?p=cloudstack.git;a=shortlog;h=4.6.0-RC20151110T1545

Commit: e31ade03c66368c64f0cd66cb7b0b754cddfb79d

Source release (checksums and signatures are available at the same
location):
https://dist.apache.org/repos/dist/dev/cloudstack/4.6.0/

PGP release keys (signed using A47DDC4F):
https://dist.apache.org/repos/dist/release/cloudstack/KEYS

Vote will be open for at least 72 hours.

For sanity in tallying the vote, can PMC members please be sure to indicate
"(binding)" with their vote?

[ ] +1  approve
[ ] +0  no opinion
[ ] -1  disapprove (and reason why)

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message