cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Remi Bergsma <RBerg...@schubergphilis.com>
Subject Re: [4.6] Instance passwords broken? "serve_password: requested password not found"
Date Fri, 16 Oct 2015 08:52:24 GMT
Do we already have an Jira issue for this? If not, please create one so we can look into it.

Thanks,
Remi




On 16/10/15 06:13, "Suresh Sadhu" <Suresh.Sadhu@citrix.com> wrote:

>Password  saved  in the right file but it's not applying on vm. its bug.
>
>You can check the  generated passwords in below file in the router :
>
>/var/cache/cloud/passwords_10.1.1.1 
>
>
>
>Regards
>sadhu
>
>
>-----Original Message-----
>From: Erik Weber [mailto:terbolous@gmail.com] 
>Sent: Friday, October 16, 2015 12:45 AM
>To: dev@cloudstack.apache.org
>Subject: Re: [4.6] Instance passwords broken? "serve_password: requested password not
found"
>
>I saw the same some weeks ago, seemed to me that the password got saved to the wrong file.
>
>Is this a basic zone?
>
>Erik
>
>Den torsdag 15. oktober 2015 skrev Nux! <nux@li.nux.ro> følgende:
>
>> Hi,
>>
>> Now that CLOUDSTACK-8923 is fixed I could move on with other testing 
>> and found out the deployed instances do not get the root/Administrator 
>> password set.
>> Looking at the logs in the VR I could see messages such as:
>>
>> 'Oct 15 17:12:27 r-4-VM passwd_server_ip.py: serve_password: requested 
>> password not found for 10.1.1.33'
>>
>> This was tested with CentOS 6, Ubuntu 14.04 and my own Macchinina 
>> templates.
>>
>> In the password script the password is attempted using wget like this:
>> 'wget -q -t 3 -T 20 -O - --header "DomU_Request: send_my_password"
>> $PASSWORD_SERVER_IP:8080'
>>
>>
>> SSH keys do work, only the passwords seem to be affected.
>>
>> Am I missing something or have I just found another bug?
>>
>>
>> Lucian
>>
>> --
>> Sent from the Delta quadrant using Borg technology!
>>
>> Nux!
>> www.nux.ro
>>
Mime
View raw message