cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Remi Bergsma <RBerg...@schubergphilis.com>
Subject Re: BVT report 10/5
Date Mon, 05 Oct 2015 21:42:41 GMT
Hi,

I looked into the reboot of the SSVM and CPVM and can reproduce the failing tests. Created
an issue:
https://issues.apache.org/jira/browse/CLOUDSTACK-8933


The failure is caused by the fact that on reboot the systemvms are not patched (patchviasocket
script), and at boot time they wait for this to happen. When I run the patch command manual
it works. See for details the above ticket.

This is KVM related, solving it fixes it both in Advanced and Basic zones.

Who can help figuring out why it isn’t patched as it should?

Regards,
Remi




On 05/10/15 21:08, "Raja Pullela" <raja.pullela@citrix.com> wrote:

>Changes in code base since last BVT report - 10/1
>-          CLOUDSTACK-8848: ensure power state is up to date when handling missing VMs
in powerReport - resmo<http://jenkins.buildacloud.org/user/resmo/> / detail<http://jenkins.buildacloud.org/job/package-rhel63-master/4393/changes#542880ae76c5e6eefbf61d42364e881495e6f3af>
>-          CLOUDSTACK-8848: added null pointer guard to new public method - Daan Hoogland<http://jenkins.buildacloud.org/user/dahn/>
/ detail<http://jenkins.buildacloud.org/job/package-rhel63-master/4393/changes#b128e567c4eacf4d22e6a8c0d6888c297c7fb726>
>Bugs -
>
>-          CloudStack-8927<https://issues.apache.org/jira/browse/CLOUDSTACK-8927>
/
>
>-          CloudStack-8923<https://issues.apache.org/jira/browse/CLOUDSTACK-8923>
/
>
>-          CloudStack-8915<https://issues.apache.org/jira/browse/CLOUDSTACK-8915>
/
>
>-          CloudStack-8876<https://issues.apache.org/jira/browse/CLOUDSTACK-8876>
/
>
>-          CloudStack-8697<https://issues.apache.org/jira/browse/CLOUDSTACK-8697>
/ related to test case failure: integration.smoke.test_internal_lb.TestInternalLb.test_internallb
>
>BVT Report - 10/5/15
>
>-          Simulator Basic - 100%
>
>-          Simulator Adv - 100%
>
>-          XS Basic - 98.6%, 1 failure
>
>-          XS Adv - 95.5%, 5 failures
>
>-          KVM Basic - 94.2%, 4 failures /another run that happened on Sunday night, test_07_reboot_ssvm
 passed but came back up?
>
>-          KVM Adv - 92.6%, 8 failures
>
>Tests failed
>XS Basic - 1 failure
>
>-          integration.smoke.test_volumes.TestVolumes.test_02_attach_volume
>XS Adv - 5 failures
>
>-          <nose.suite.ContextSuite context=TestNiciraContoller>:setup
>
>-          integration.smoke.test_loadbalance.TestLoadBalance.test_01_create_lb_rule_src_nat
>
>-          integration.smoke.test_loadbalance.TestLoadBalance.test_02_create_lb_rule_non_nat
>
>-          integration.smoke.test_loadbalance.TestLoadBalance.test_assign_and_removal_lb
>
>-          integration.smoke.test_internal_lb.TestInternalLb.test_internallb
>KVM Basic - 4 Failures
>
>-          integration.smoke.test_vm_life_cycle.TestVMLifeCycle.test_10_attachAndDetach_iso
>
>-          integration.smoke.test_volumes.TestVolumes.test_02_attach_volume
>
>-          integration.smoke.test_ssvm.TestSSVMs.test_07_reboot_ssvm
>
>-          integration.smoke.test_ssvm.TestSSVMs.test_08_reboot_cpvm
>KVM Advanced - 8 Failures
>
>-          integration.smoke.test_loadbalance.TestLoadBalance.test_01_create_lb_rule_src_nat
>
>-          integration.smoke.test_loadbalance.TestLoadBalance.test_02_create_lb_rule_non_nat
>
>-          integration.smoke.test_loadbalance.TestLoadBalance.test_assign_and_removal_lb
>
>-          <nose.suite.ContextSuite context=TestNiciraContoller>:setup
>
>-          integration.smoke.test_snapshots.TestSnapshotRootDisk.test_01_snapshot_root_disk
>
>-          integration.smoke.test_ssvm.TestSSVMs.test_07_reboot_ssvm
>
>-          integration.smoke.test_ssvm.TestSSVMs.test_08_reboot_cpvm
>
>-          integration.smoke.test_internal_lb.TestInternalLb.test_internallb
Mime
View raw message