cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wido den Hollander <w...@widodh.nl>
Subject Re: RPM Build from Source Fails for CentOS 7.x
Date Mon, 14 Sep 2015 07:54:01 GMT


On 14-09-15 08:35, Keerthiraja SJ wrote:
> Hi All,
> 
> After I follow the doc to build rpm from source there seems to be some
> basic issue.
> 
> First the source is looking for the tomcat6 and @ the same time inside the
> source I could see only
> /root/apache-cloudstack-4.5.2-src/packaging/centos63 directory.
> 

For 4.5 there is no official CentOS 7 support. That is the main problem.

4.6 will have CentOS 7 support.

> Even if I try to run the ./package.sh I could see the below error
> 
> Error
> ===
>  ./package.sh
> -D_os default
> Preparing to package Apache CloudStack 4.5.2
> . preparing source tarball
> . executing rpmbuild
> error: Failed build dependencies:
>     tomcat6 is needed by cloudstack-4.5.2-1.el7.centos.x86_64
> RPM Build Failed
> [root@localhost centos63]# pwd
> /root/apache-cloudstack-4.5.2-src/packaging/centos63
> 
> Is there any way I can do for CentOS 7.x
> 
> On CentOS 7.x the default tomcat package is 7.
> 
> Thanks,
> Keerthi
> 

Mime
View raw message