cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wido den Hollander <w...@widodh.nl>
Subject Re: Repo CS 4.5 for CentOS 7.x Missing
Date Sun, 13 Sep 2015 13:17:40 GMT


On 09/13/2015 01:28 PM, Remi Bergsma wrote:
> Hi Wido,
> 
> PR 731's patch does not apply cleanly on 4.5 due to a conflict in LibvirtComputingResource.java.
It doesn't look too complicated (just one conflict), but I'd rather have one of the Java gurus
look at this. I just cherry-picked the commits to a new branch (branched off of 4.5).
> 

Understood. I haven't checked that.

> 757 does apply cleanly. Any time to look into it and resolve the conflict, then push
a PR? I'd prefer sending all commits from both PRs in one new PR against 4.5. They have the
same goal anyway, and otherwise I'll have issues testing, as I'll hit the MariaDB bug again.
> 

True, that should be doable.

I also created a PR with a systemd profile for the Agent:
https://github.com/apache/cloudstack/pull/813

Wido

> I can setup a test environment to verify it, once the PR is there.
> 
> Regards, Remi
> 
> 
> -----Original Message-----
> From: Wido den Hollander [mailto:wido@widodh.nl] 
> Sent: zondag 13 september 2015 11:28
> To: dev@cloudstack.apache.org
> Subject: Re: Repo CS 4.5 for CentOS 7.x Missing
> 
> 
> 
> On 09/13/2015 10:47 AM, Remi Bergsma wrote:
>> Hi,
>>
>> The question is, is CentOS7 even supported on 4.5? The docs say it isn’t and when
we were voting for 4.5.2 (http://markmail.org/message/36vnwh4kiilhkunu) I found some issues
with CentOS 7. Regarding the KVM agent, that doesn’t work properly on 4.5 (which is now
fixed on master). You can usually manually work around the issues, but it doesn’t work out-of-the
box. If we want this, let’s bring the changes to 4.5 and make a new release.
>>
>> Also, MariaDB on CentOS 7 also has a problem. Or better, we made a query that crashes
it resulting in unable to finish loading the db. This also was fixed on master, and not on
4.5 yet. This has recently been on the user@ list a few times.
>>
>> Looks like there is demand for CentOS7 support. But let’s then make 
>> sure it actually works :-)
>>
> 
> Indeed!
> 
>> At least we need those PRs to be back ported to 4.5 (and then test it):
>>
>> https://github.com/apache/cloudstack/pull/731
>> https://github.com/apache/cloudstack/pull/757
>>
> 
> True. The MariaDB fix seems fine with me, but we need #731 as well.
> 
> I'm however a Ubuntu guy, so I don't know that much about CentOS and testing :)
> 
> Wido
> 
>> Regards,
>> Remi
>>
>>
>>
>>
>> On 13/09/15 09:25, "Keerthiraja SJ" <sjkeerthi@gmail.com> wrote:
>>
>>> When will the 7.x rpm's will get uploaded.
>>>
>>>
>>>
>>> On Sun, Sep 13, 2015 at 6:12 AM, Pierre-Luc Dion <pdion@cloudops.com> wrote:
>>>
>>>> There is one:  http://jenkins.buildacloud.org/view/build-release/  
>>>> but the job is failing, I'm still not sure if it's the jenkins slave the
problem.
>>>>
>>>>
>>>> PL
>>>>
>>>>
>>>> On Sat, Sep 12, 2015 at 5:20 PM, Wido den Hollander <wido@widodh.nl>
>>>> wrote:
>>>>
>>>>> I don't see a Jenkins job for CentOs 7. Do we even have one?
>>>>>
>>>>>
>>>>>
>>>>>> Op 12 sep. 2015 om 19:29 heeft Keerthiraja SJ 
>>>>>> <sjkeerthi@gmail.com>
>>>> het
>>>>> volgende geschreven:
>>>>>>
>>>>>> Hi All,
>>>>>>
>>>>>> I could see there is no packages under the directory.
>>>>>>
>>>>>> http://cloudstack.apt-get.eu/rhel/7/4.5/
>>>>>>
>>>>>> During the instillation of CS 4.5.2 on CentOS 7.x I could see 
>>>>>> while pointing the repo from 
>>>>>> http://cloudstack.apt-get.eu/rhel/7/4.5/ to 
>>>>>> http://cloudstack.apt-get.eu/rhel/4.5/
>>>>>>
>>>>>> ---> Package xml-commons-resolver.noarch 0:1.2-15.el7 will be

>>>>>> ---> installed
>>>>>> --> Finished Dependency Resolution
>>>>>> Error: Package: cloudstack-common-4.5.2-1.el6.x86_64 (cloudstack)
>>>>>>           Requires: python(abi) = 2.6
>>>>>>           Installed: python-2.7.5-18.el7_1.1.x86_64 (@updates)
>>>>>>               python(abi) = 2.7
>>>>>>               python(abi) = 2.7
>>>>>>           Available: python-2.7.5-16.el7.x86_64 (base)
>>>>>>               python(abi) = 2.7
>>>>>>               python(abi) = 2.7
>>>>>> Error: Package: cloudstack-management-4.5.2-1.el6.x86_64 (cloudstack)
>>>>>>           Requires: tomcat6
>>>>>> You could try using --skip-broken to work around the problem You

>>>>>> could try running: rpm -Va --nofiles --nodigest
>>>>>>
>>>>>>
>>>>>> So kindly update the Cloudstack 4.5.2 for the 7 Version.
>>>>>>
>>>>>> Thanks,
>>>>>> Keerthi
>>>>>
>>>>

Mime
View raw message